Weird keyboard behavior when Software Update window is open at final step

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: dean_tessman, Assigned: bugs)

Tracking

({access})

1.7 Branch
x86
Windows XP
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [asaP2])

(Reporter)

Description

14 years ago
1. Launch software update and wait for it to get to the final step.  For me
right now, that's "Firefox encountered problems".
2. Select some text in a page.
3. Copy the text to the clipboard using Ctrl+C.
4. Paste the copied text.

Expected Results: Text is pasted.

Actual Results: Previous clipboard contents are pasted, meaning that text was
never copied.  Copying-and-pasting works fine.  This is only one way to
demostrate the bug.  When this is happening I also have problems typing in text
fields.  Incremental search always kicks in, and presing Backspace navigates
back a page.  If switch to the update dialog, I notice that Finish doesn't have
focus.  If I press Tab to focus the Details button, everything starts working again.
(Reporter)

Comment 1

14 years ago
Also, browser.urlbar.clickselectsall doesn't work while the Update dialog is open.

Updated

14 years ago
Whiteboard: [asaP2]

Updated

13 years ago
Version: unspecified → 1.0 Branch

Updated

13 years ago
Keywords: access
(Reporter)

Comment 2

12 years ago
I can't reproduce this using 20061124 Minefield/3.0a1.  I'll re-open this bug if I hit this problem again.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.