General 'Selecting' enhancements

RESOLVED DUPLICATE of bug 268709

Status

RESOLVED DUPLICATE of bug 268709
14 years ago
12 years ago

People

(Reporter: ThomasZillinger, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

I think that sunbird should act the same when selecting hours/days in all views,
not as it is implemented right now, that selecting a day in multiweek/month view
would select they day and in weekview/day view it would not.

Instead the following should be the case:
.) Clicking on hours:day view; days:week/multiweek/month view should select 
   it with the bright-blue filled rectangular as already implemented for 
   multiweek/month view. 
.) drag&drop should ONLY work on selected events/task and NOT with selecting
   multiple hours/days, instead...
.) Shift-drag will select multiple hours & days: 
   -) In week view, you should be able to select hour-blocks, say
      14-15:00 on Mo/Tue/Wed; 
   -) In multiweek/month view, block selections (like above) should not be 
      possible, because this would not be the expected behaviour. But whole
      weeks should be selectable. Clicking on monday, Shift-Click on 
      next weeks thuesday should then select the whole week.
.) Strg(or Ctrl)-Click, should make selections of multiple, individual hours and 
   days possible.

.) The whole day in day view should be selectable when clicking above the top 
   of the table of hours. Similar in week view, when clicking the weekdays name
.) Clicking on hours (eg 8-9h) in week view should select all (8-9) hours of the 
   week
.) Clicking on weekday names in multiweek/month should select all weekdays of
   the month
.) Clicking on weeknumber in multiweek/month view should select all days in this 
   week

Ok i think you got the idea - it's quite similar to any spreadsheet application
or other table oriented applications around. Right-clicking on those selections
may only expose certain functionality depending on what i selected.

Regards
Tom

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 268709 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
yep sorry - committed twices since bugzilla wrote something of an Internal
Server error... :)
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.