The default bug view has changed. See this FAQ.

can't use drag and drop a list item (a link/an image URL) to Location Bar (for example)

RESOLVED INVALID

Status

()

Firefox
Page Info Window
--
minor
RESOLVED INVALID
13 years ago
4 years ago

People

(Reporter: Miha Filej, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

In the page info you can normally drag an URL, let's say, in the URL-bar, to
make the browser load that address. It is not the case with a list item. When
trying to drop the grabbed item nothing happens, the "denied" mouse pointer can
be seen.

Reproducible: Always
Steps to Reproduce:
1. Open the Page Info dialog (Tools > Page Info)
2. Select the Links tab
3. Drag an item somewhere

Actual Results:  
The dragged item cannot be dropped.

Expected Results:  
Allow the item to be dropped.

about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -nologo -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -nologo -Gy -Fd$(PDBFILE)

Configure arguments
--disable-ldap --disable-mailnews
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth
--enable-crypto --disable-composer --enable-single-profile
--disable-profilesharing --enable-optimize --disable-debug --disable-tests
--enable-static --disable-shared --enable-official-branding

Comment 1

13 years ago
WFM on Mac builds Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.5) Gecko/20041107 Firefox/1.0
I have verified that this happens.

On the following code:

a href="#test"

and

a name="#test"

Netscape's Mozilla 7.X and firefox 1.0 will not recognize these as named
anchors, thus preventing users from using the link so provided within the document.
(In reply to comment #2)
> Netscape's Mozilla 7.X and firefox 1.0 will not recognize these as named
> anchors, thus preventing users from using the link so provided within the
document.

How that comment is relevant to this bug in any way is escaping me. The reason
that is happening is because the <a name=""> part should not include the "#".

Now back to this actual bug, the seamonkey bug related to this is bug 69295 (I
think).

Comment 4

12 years ago
confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050401 Firefox/1.0+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: can't use drag&drop feature with a list item → can't use drag and drop a list item (a link/an image URL) to Location Bar (for example)
Version: unspecified → Trunk
Assignee: bugs → nobody
WFM?  The only place URL's can be dragged in 3.5's page info is from "Media" and that drags fine to location bar.

Comment 6

8 years ago
Created attachment 399542 [details]
drag and drop a list item to the location bar

Comment 7

8 years ago
Comment on attachment 399542 [details]
drag and drop a list item to the location bar

Possible malware/virus. Do Not download!
Attachment #399542 - Attachment mime type: text/plain → application/octet-stream
There is no longer a Links pane in the Page Info window. Marking this as INVALID.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.