All users were logged out of Bugzilla on October 13th, 2018

"Close tab" and "Close other tabs" does nothing

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: mozilla.org, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040910

Unable to close tabs either by clicking the [X] button or by <ctrl>-clicking
(right-clicking) and selecting from context menu.  



Reproducible: Always
Steps to Reproduce:
1. invoke 2 or more tabs
2. try to remove/delete any tab or group of tabs by any of the usual methods 


Actual Results:  
Nothing happens. (i.e., no tabs close)

Expected Results:  
Tabs should close.

This problem began when I upgraded from mozilla 1.7.2 to 1.7.3
Are there any errors in the JS console?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Are there any errors in the JS console?

Indeed there are: If I try to close one tab, I get:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://undoclosetab/content/undoclosetab.xul :: removeTab :: line 68"  data: no]

If I try to "close all other tabs" I get:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIWebProgress.removeProgressListener]" 
nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
chrome://undoclosetab/content/undoclosetab.xul :: removeTab :: line 47"  data: no]
(Reporter)

Comment 3

14 years ago
Further observation: When I close an entire window containing more than one tab,
 I no longer get a warning that I am about to close a window containing mutiple
tabs. 
Sounds like a bug in the "undoclosetab" thing, whatever it is (an extension?)
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> Sounds like a bug in the "undoclosetab" thing, whatever it is (an extension?)

Found a JAR file by that name in the CHROME directory. Removed it and everything
seems to be back to normal. 

I do recall installing that extension but it never worked so I promptly forgot
about it. Guess it came back to haunt me. :-)

I hereby mark this bug Resolved:INVALID.

Thanks for the help, everybody!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.