Problems in calling user javascript method with the name "mouseOver"

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: vitaly.zilberman, Assigned: igor)

Tracking

1.5R1
x86
Windows 2000

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: rhino1_5R4.1

The user html has a javascript which defines a method with the name "mouseOver" 
and expects 2 parameters. An attempt to invoke the method leads to a member 
method "mouseOver" to be found instead of the user's one and thus to an 
exception on parameters types mismatch.

Attached here is the html example:
<HTML>
<HEAD>
<TITLE> mouseOver Test </TITLE>
</HEAD>

<BODY>
<SCRIPT LANGUAGE="JavaScript">
<!--
function mouseOver(x,y) {
	alert("Mouse over test " + x + " " + y);
}
//-->
</SCRIPT>
<A HREF="www.amazon.com" onmouseover = "mouseOver('Mouse 
over', 'succeeded')"><B>Amazon</B></A>
</BODY>
</HTML>


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Client-side JavaScript: org.mozilla.javascript.EvaluatorException: Can't find 
method "somePackage".mouseOver(string,string). (A:onmouseover#1(eval); line 1)


Expected Results:  
The user defined method to be invoked.
I suspect you meant to file this under either Browser (Mozilla) or Firefox, but
since you used IE to file it I have no clue which you meant.  This definitely
isn't Bugzilla, so we either need to move the bug or close it.  Can you clarify
what product you meant to report this against?
(Reporter)

Updated

14 years ago
Component: Bugzilla-General → Compiler
Product: Bugzilla → Rhino
Version: unspecified → 1.5R1
Assignee: justdave → igor
QA Contact: mattyt-bugzilla → pschwartau
(Assignee)

Comment 2

14 years ago
This is not a Rhino bug since Rhino is just an engine implementing ECMAScript
standard and the problem AFAICS is in an application that uses Rhino. Please
contact its developers instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.