Error loading stylesheet: An XSLT stylesheet does not have an XML mimetype

RESOLVED INVALID

Status

()

Firefox
File Handling
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: René de Leeuw, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I'm developing an ASP file wich prints XSLT data to the browser. The included
file in the XML file has the extention ASP.

The error 'Error loading stylesheet: An XSLT stylesheet does not have an XML
mimetype' is raised by the interpretor of FireFox. In IE it's possible to use
different extentions.

Reproducible: Always
Steps to Reproduce:
1. Create a generated XSLT stylsheet and use the ASP file extention
2. Include/link it in the XML file
3. Open the URL to the xml file

Actual Results:  
The next error apears: Error loading stylesheet: An XSLT stylesheet does not
have an XML mimetype

Expected Results:  
Show the HTML output.

Comment 1

14 years ago
reporter: you didn't include a url, and this bug isn't valid without one. the
bug is a bug in whichever site it was, had you provided a url we could reassign
this bug to evangelism. we're required by spec to honor the mime type, and we do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> reporter: you didn't include a url, and this bug isn't valid without one. the
> bug is a bug in whichever site it was, had you provided a url we could reassign
> this bug to evangelism. we're required by spec to honor the mime type, and we do.

OK. I understand that the mimetype should be honored. Only XML pages with other
types then XSLT or XSL can be viewed with IE only. That's a disadvantage in my
opinion for Mozilla Firefox.

I can't provide a URL because the pages are in development now.
You need to log in before you can comment on or make changes to this bug.