Race condition in parallel make

RESOLVED INVALID

Status

()

Core
Build Config
--
minor
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Tatjana Heuser, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020921 Netscape/7.0
Build Identifier: firefox-1.0-source.tar.bz2

gmake -j stumbled into a race condition when a make process needed
unix/gtk2/libviewer_gtk2_s.a before it was built by a parallel process.

Reproducibility might be errant/depending on # of CPUs (4 in this case) and load. 

Reproducible: Didn't try
Steps to Reproduce:
SunOS mir 5.9 Generic_117171-09 sun4u sparc SUNW,UltraAX-MP
System Configuration:  Sun Microsystems  sun4u UltraAX-MP+ WorkServer (4 X
UltraSPARC-II 296MHz)
Memory size: 2048 Megabytes

.mozconfig:
-----------
. $topsrcdir/browser/config/mozconfig
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/OBJ-mozilla
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-xft
ac_add_options --disable-test

ac_add_options --enable-calendar
ac_add_options --enable-xinerama
ac_add_options --enable-js-ultrasparc
ac_add_options --enable-xterm-updates
ac_add_options --prefix=/opt/csw
ac_add_options --with-gtk-prefix=/opt/csw
#ac_add_options --enable-native-uconv # iconv 1.9.2 in /opt/csw wasn't detected
ac_add_options --disable-freetype2

Environment:
------------
PKG_CONFIG_PATH=/opt/csw/lib/pkgconfig
LDFLAGS=-L/opt/csw/lib -R/opt/csw/lib
CPPFLAGS=-I/opt/csw/include

Command to build:
gmake distclean ; ksh ../configure ; gmake -j SHELL=ksh


Actual Results:  
[3]: *** No rule to make target `unix/gtk2/libviewer_gtk2_s.a', needed by
`viewer'.  Stop.
gmake[3]: *** Waiting for unfinished jobs....
[...]
rm -f libviewer_gtk2_s.a
ar cr libviewer_gtk2_s.a nsGtkMain.o nsGtkMenu.o  
ranlib libviewer_gtk2_s.a
/tmp/mozilla/OBJ-mozilla/config/nsinstall -R -m 644 libviewer_gtk2_s.a
../../../../../dist/lib
gmake[5]: Leaving directory
`/tmp/mozilla/OBJ-mozilla/webshell/tests/viewer/unix/gtk2'
gmake[4]: Leaving directory `/tmp/mozilla/OBJ-mozilla/webshell/tests/viewer/unix'
gmake[3]: Leaving directory `/tmp/mozilla/OBJ-mozilla/webshell/tests/viewer'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/tmp/mozilla/OBJ-mozilla/webshell/tests'
gmake[1]: *** [tier_99] Error 2
gmake[1]: Leaving directory `/tmp/mozilla/OBJ-mozilla'
gmake: *** [default] Error 2


Expected Results:  
I am not familiar with gmake and don't know how dependencies are handled for
parallel builds. - hence no fix. Since the offending library was built by a
parallel process in the above example, I just restarted gmake to have it pass
past this point. (Compile completed successfully afterwards)

Updated

13 years ago
Assignee: bryner → nobody
Status: UNCONFIRMED → NEW
Component: Build Config → Build Config
Ever confirmed: true
OS: SunOS → All
Product: Firefox → Core
QA Contact: asa → build-config
Hardware: Sun → All
Version: unspecified → Trunk

Comment 1

12 years ago
Viewer has been removed (bug 121881) so this is no longer an issue.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.