Bug 268905 (RemoteScripting)

Remote Scripting Applet Fails

RESOLVED INCOMPLETE

Status

defect
RESOLVED INCOMPLETE
15 years ago
8 years ago

People

(Reporter: fernando.wendt, Unassigned)

Tracking

Dependency tree / graph
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This version of Firefox (1.0), doesn´t recognize the remote script applet. On
0.9 version it works fine. The message it returns is "ERROR: Cannot locate proxy
wich supports Remote Scripting. Was RSEnableRemoteScripting method invoked?".
Then, it follows: "Failed to create ASP object for myfile.asp".

Again, it works on Firefox 0.9, but now this seens to be diferent.

Thats all.

Reproducible: Always
Steps to Reproduce:
1.Adding the RemoteScripting applet on some page
2.Accessing the URL
3.When page loads, the message appears.

Actual Results:  
The JavaScript window alert appears, twice. The two messages where pointed.

Expected Results:  
Interpreted the RemoteScripting normally, as in version 0.9. 

Once my system is running at our Intranet, here are some sample pages using this
resource:

http://krystalware.com/wiki/default.aspx/KrystalWiki.RemoteScripting
http://www.aspfree.com/index2.php?option=content&task=view&id=1864&pop=1&page=0&hide_js=1
http://www.ashleyit.com/rs/
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/rmscpt/Html/rmscpt.asp
(i know, i know, but it referes too)
http://www.learnasp.com/learn/remotescripting.asp
Reporter

Comment 1

15 years ago
The Remote Scripting Applet resource is failing at the release 1.0 of Firefox,
but it works on 0.9.
Alias: RemoteScripting
Keywords: js1.5
Summary: remote script applet fails → Remote Script Applet Fails
Reporter

Updated

15 years ago
Summary: Remote Script Applet Fails → Remote Scripting Applet Fails

Comment 2

15 years ago
I confirm this bug's existence on http://www.whereismybus.com and think that
when this and a few other critical rendering bugs are fixed, we should release a
"minor" new version, 1.0.1.

Updated

15 years ago
Flags: blocking-aviary1.1?

Comment 3

15 years ago
Wrong component. I don't know what is remote scripting applet is, but if that
doesn't work with nightly Mozilla Suite builds, you should move this bug to Core
product.
Assignee: bugs → firefox
Component: JavaScript Console → General
QA Contact: js-console → general

Comment 4

15 years ago
It does not work in App Suite 1.8 Alpha 6 either, should be changed to core.

Comment 5

15 years ago
I confirm the existance of this bug as well, it is also manifested on
http://www.windev.org (search for a keyword that is likely to be found in
Windows developers' discussions, e.g., "bitmask" or "MFC" without the quotes)

Comment 6

15 years ago
Note that this is *not* a javascript bug, it is a failure to load RSProxy.class.
 A javascript wrapper reports the problem, but it's not a failure that occurs in
javascript.  The object associated with the APPLET tag for this class is not
getting created properly, in the DOM Inspector it's length = 0.
This is caused by bug 268945. |typeof(document.RSAspProxyApplet)| returns
'function' instead of 'object'. A workaround is to add check in
_MSRS_startRequest for (typeof(document.RSAspProxyApplet) == 'function').
Assignee: firefox → nobody
Severity: critical → normal
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Depends on: 268945
Ever confirmed: true
Keywords: js1.5
OS: Windows 2000 → All
Product: Firefox → Core
QA Contact: general → plugins
Hardware: PC → All
Version: unspecified → Trunk

Updated

14 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Reporter

Updated

14 years ago
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Fernando, why did you mark this bug as fixed?
Reporter

Comment 9

14 years ago
Sorry, update wrong bug...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

14 years ago
For my money, if anyone is interested, the work-around that Gavin provided 
constitutes a fix.  The javascript functions that come with Remote Scripting 
are inconsistent, and use the same test suggested in the workaround, in other 
similar branches of the code.

So, imho, the bug is in Remote Scripting, that it worked before was a fluke, 
and the work-around fixes that bug in Remote Scripting.  I have updated all 
copies of it I have deployed, it's compatible with all browsers I've tested.

Just my 2 cents for whatever it's worth.
Reporter

Comment 11

14 years ago
Yes, thats true. I have take a look at him, and it really get works when 
editing the JavaScript config file from RemoteScript Applet. You just have to 
enhace the block where its test Mozilla compability - with a object, adding 
function.

But in metter of facts, the way Mozilla handled it have chaged from version 0.9 
to 1.x, and by this fact, who have changed is Mozilla, not the RemoteScript 
mecanism by self.

So then, as its possible to make RemoteScript works with current versions on 
Mozilla, i pretend do close this bug. Anyone envolved have some additional 
comment?
As I indicated earlier, the reason this fails in newer builds is because of bug
bug 268945. That bug may or may not be fixed, so it's outcome would determine
this bug's. If, however, Microsoft makes changes to the code to adapt to the new
return value, this bug should probably be closed.
Reporter

Comment 13

14 years ago
OK, let´s go leaving it open.
Plus: if there is someone trying to get RemoteScripting working by time, just
find and edit the line above.

I give my 2 cents as a contribution to Mozilla Software Foundation, there is no
coast :)

--- File "rs.htm"

  if (typeof(document.RSAspProxyApplet) == 'object' ||
typeof(document.RSAspProxyApplet) == 'function')

Best regards every one have been looking for help about this resource, specially
those ones who have posted messages here.

Updated

14 years ago
Assignee: nobody → live-connect
Status: REOPENED → NEW
Component: Plug-ins → Java: Live Connect
QA Contact: plugins → pschwartau

Updated

14 years ago
Blocks: 306479

Comment 14

14 years ago
Still not working on the latest version of Firefox.

Updated

14 years ago
Flags: blocking-aviary2?
The cause of this "bug" is bug 268945, so the blocker nomination should be put there.
Flags: blocking-aviary2?

Updated

9 years ago
Product: Core → Core Graveyard
Firefox code moved from custom Liveconnect code to the NPAPI/NPRuntime bridge a while back. Mass-closing the bugs in the liveconnect component which are likely invalid. If you believe that this bug is still relevant to modern versions of Firefox, please reopen it and move it the "Core" product, component "Plug-Ins".
Status: NEW → RESOLVED
Closed: 14 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.