Closed Bug 268959 Opened 17 years ago Closed 17 years ago

incorrect rendering of the page with big <PRE> tag

Categories

(Core :: Web Painting, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: ivanoe, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Give above URL as of today does not render properly.
It is ok when using IE 6.0, but Firefox 1.0 seems to have a problem with one
very big <PRE> tag.

Reproducible: Always
Steps to Reproduce:
1. Visit the mentioned link:
http://projects.edgewall.com/trac/attachment/wiki/NewWorkflow/patch-newworkflow-r1003.diff
2. Try to scroll down or just go to the end of the page


Actual Results:  
3. And one should notice about 30% of the total screen is a graphical mess.

Expected Results:  
render correctly the page
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: firefox.general → general
Version: unspecified → Trunk
Attached file reduced testcase
Reduced testcase.  What we have here is a single div, set to overflow:auto,
containing a single pre tag, which contains a monster hunk of text (about 85kb)


If you scroll the document, starting about 16,300-something (16384?) pixels
down from the top, repainting fails and the browser window just shows scrolling
junk artefacts.
Confirming, ->Layout: view rendering
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: View Rendering
Ever confirmed: true
Keywords: testcase
Aha.

*** This bug has been marked as a duplicate of 215055 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.