Linux - Ctrl-u in a text field no longer clears line -- opens view source

VERIFIED DUPLICATE of bug 260188

Status

()

Firefox
Shell Integration
--
minor
VERIFIED DUPLICATE of bug 260188
14 years ago
14 years ago

People

(Reporter: Mike Waychison, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041105 Firefox/1.0RC1 (Debian package 0.99+1.0RC1-4)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041105 Firefox/1.0RC1 (Debian package 0.99+1.0RC1-4)

Up until at least firefox 0.9, hitting ctrl-u would do the 'unix thing' and
clear the current line of text as you are entering it.  After updating to a more
recent version, this no longer works, and will pop up the 'view source' dialogue
regardless of the context.

The behaviour before was that ctrl-u would do 'view source' if the page had
context.  It would clear line in a textarea or text field before.  It also used
to clear the url input and search input iff they had focus.  This is no longer
the case.

I haven't been able to find any config option to revert back to the old
behaviour, which imho is the right thing to do on Unix platforms.

Reproducible: Always
Steps to Reproduce:
1.  Click on url bar
2.  Hit ctrl-u

Actual Results:  
'view source' pops up

Expected Results:  
the url input should be cleared.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 260188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.