Mails received disappear when you move some of them to other folder and group by sort option is selected

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
General
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: Ivan Cano Martinez, Assigned: Bienvenu)

Tracking

unspecified
Thunderbird1.1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This happens in all the folders. I have group by sort option selected and the
mails are sort by sender. When i move one of them to other folder, some of the
others mails dissapear(Sender group)  . If i want to see them again i must go to
other folder and go back again to the same folder.

Reproducible: Always
Steps to Reproduce:
1.Sort by sender in the inbox.
2.Enable group by sort option.
3.Move one of the message to other folder

Actual Results:  
Messages in others groups dissapear,even if you can see the header(sender)

Expected Results:  
They must show all the message.

Im using noia/cute verrsion  1.4.4 theme
(Reporter)

Comment 1

14 years ago
Sorry. I just check it and only happens in inbox folder
(Assignee)

Comment 2

14 years ago
this works fine for me - what version of thunderbird are you using?
(Reporter)

Comment 3

14 years ago
Last version 0.9 in Wxp with service pack 2 installed.
Theme is noia 1.4.4
(Assignee)

Comment 4

14 years ago
are you including the "dummy" header line that just has the sender name when you
do the move? I believe that will cause us to get the counts wrong in the thread
pane...
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Thunderbird1.0
(Reporter)

Comment 5

14 years ago
Additional Info. 

The account us ssl connection.

Only happens in this account. I have others accounts(each one with their own folder)

Im moving the message, not the header.

I hope that it will be ussefull.
(Reporter)

Comment 6

14 years ago
Created attachment 165643 [details]
Final state when move an e-mail

The pic show the inbox mailbox when i move an e-mail from it to other folder.
In mailbox there is only a sender and if you see the header of the e-mail that
its in preview, its belown to other e-mail. This last email still exist in the
inbox folder but i need to click to other folder and go back to look it again.
(Reporter)

Comment 7

14 years ago
I added a pic that what is the status of the inbox when I move an email from
here to other folder. Explained in attachemnt.
(Assignee)

Comment 8

14 years ago
did you end up with only one message left in the folder? it's hard to tell from
the screen capture...
*** Bug 267728 has been marked as a duplicate of this bug. ***
Summary: Mails received dissapear when you move some of them to other folder and group by sort option is selected → Mails received disappear when you move some of them to other folder and group by sort option is selected
(Assignee)

Comment 10

14 years ago
Ivan, is this an imap folder or a local folder? I can't reproduce this problem
myself...I'm using the 11/16 .9+ build...
(Assignee)

Comment 11

14 years ago
Can any QA folks reproduce this and give me steps? I've tried and failed...
(Reporter)

Comment 12

14 years ago
Its a local folder
(Assignee)

Comment 13

14 years ago
time is short, moving off - I was never able to reproduce this...
Target Milestone: Thunderbird1.0 → Thunderbird1.1

Comment 14

14 years ago
I confirm this bug and try to give a better description:
1. Sort your inbox by date and activate the Group By sorting
2. Create (if you don't have one) a subfolder under Inbox
3. Move all af the messages of the "Today" group in the subfolder

Expected result: Only the "Today" group disappears

Actual result: The "Today" and the "Yesterday" groups both disappear

Workaround: Change focus to another folder and change back to inbox; the
Yesteray group is back.

This happens whatever group is the one preceding the group the messages get
deleted from.

Comment 15

13 years ago
*** Bug 275781 has been marked as a duplicate of this bug. ***
Created attachment 177104 [details]
Effect after undoing a move that made messages disappear

I can confirm and it is easily reproducible. It happens every time you move all
messages (even if it's only one) of a group to another folder. The destination
folder does not need to be a subfolder of the Inbox. The originating folder
does not need to be an IMAP folder or the Inbox. The only necessary thing is
for a group to become empty.

The effect is that at least one message of the group above the one that becomes
empty dissapears; my guess is that the number of messages that disappear is the
same as the number of messages that get moved, but I couldn't confirm that.

Undoing the move with Ctrl-Z generates a very weird effect, as is visible in
the attached image.

Comment 17

13 years ago
Additional info:

When you try to collapse the group containing the message that just disappeared
(by clicking the minus sign in front of the group name) the entire group
disappeares.

Again, changing focus to a different folder and changing it back to the inbox
restores the display.

I'm using Thunderbird 1.0.2.
(Assignee)

Comment 18

13 years ago
Created attachment 186606 [details] [diff] [review]
proposed fix

when batching is turned on, as indicated by m_deletingRows, we just need to add
the index to remove to mIndicesToNoteChange, and nsMsgDBView::OnDeleteCompleted
will handle removing the dummy header.
Attachment #186606 - Flags: superreview?(mscott)

Updated

13 years ago
Attachment #186606 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

13 years ago
Attachment #186606 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #186606 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 19

13 years ago
*** Bug 273987 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.