powertip.com.tw - proprietary JS for navigation

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
14 years ago
4 years ago

People

(Reporter: john, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041110
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041110

When navigating to the home page (or any page for that matter) the dark blue
menu bar which allows entering the site, just below the logo, spanning the
entire width, doesn't show.
I suppose it shows in IE, can't test that, but it does show in Opera. (not in
Firefox)

Reproducible: Always
Steps to Reproduce:
1. Just go to the site above
2.
3.

Actual Results:  
Menubar is missing

Expected Results:  
Show it

I suspect the page is poorly coded - still, I wonder if it wouldn't be better to
show something instead. I thought it was related to 177737, but doesn't seem
like it.

The code starts with:

<SPAN id=menubar    
style="POSITION: relative; VISIBILITY: hidden">   

but - I'm no guru - then proceeds to enable it with a Javascript.

Comment 1

14 years ago
if(document.all) { document.all["menubar"].style.visibility = "visible"; }   
else if(document.layers) { document.layers["menubar"].visibility = "visible"; }  

document.all is for IE.
document.layers is for Netscape 4.

So it can never work in Mozilla.

The site needs to rewrite their scripts to support standards-based scripting
solutions.  You might write to them and suggest it.
-->TE
Assignee: roc → english-other
Status: UNCONFIRMED → NEW
Component: Layout: View Rendering → English Other
Ever confirmed: true
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: ian → english-other
Hardware: PC → All
Summary: Selection menubar doesn't show → powertip.com.tw - proprietary JS for navigation
Version: Trunk → unspecified
(Reporter)

Comment 2

14 years ago
Ok... I suspected as much, and I've sent a mail to the webmaster (two e-mail
links on the page don't work either).
I wonder if it would be worthwhile to be on the safe side and - like in this
case - it would be more useful to show the information, even though it isn't
correct code. I believe this has been the general rule in HTML, but I realize
this is not such a simple case.
Thanks for replying so quickly, and feel free to close the bug if you think
that's best.

Comment 3

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.