Deleting mail does not move it to a trash folder on IMAP server

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: thunderbird, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In prefs you can specify that mail when trashed should be moved to a trash
folder. I have done this for my account on an imap server.  When I delete mail,
the thunderbird interface shows the mail moved to the trash folder. Internal to
the IMAP server, however, it has only been marked as deleted. 

What I desire is that the mail is really moved to a trash folder on the imap
server as soon as I tell thunderbird to do so. Currently, however, the mail is
never moved to a trash folder.

Why is this important? Mostly because I use multiple mail readers depending on
context (web, pine, and thundirbird) and marking mail as deleted is not
consistently interpreted by all, whereas placing the mail in a separate mailbox is. 

Reproducible: Always
Steps to Reproduce:
1. tools > account settings > server settings > when I delete a message: "move
it to the trash folder"
2. delete a message from the inbox (thunderbird now shows it in the trash)
3. log into the imap server directly and find the message still in the inbox.

Actual Results:  
mail marked as deleted

Expected Results:  
mail moved to "Trash" folder

Comment 1

14 years ago
I have the same kind of problem : when "move 
it to the trash folder" on an imap server, and when I want to delete a message, then the 
message diseappears but does not go to the trash folder 
 
However, if I do the followings : 
- select the local mail account 
- select the imap server account 
then the icon of the trash is no longer the same, and now if I try to delete a message, it will 
be moved to the trash folder, as expected. 
 
So the problems are : 
- I need to select another mail account in order to be able to move messages to the trash 
folder when I delete them, which is strange 
- when I start thunderbird again, I need to do the manipulation describes above if I want the 
messages to be moves to the trash folder 
 
I hope this will help confirm the bug (which I noticed on both windows and linux (french) 
versions) 
  

Comment 2

14 years ago
WFM with both TB 1.0.2 and the latest trunk (20050323). Deleted messages are
*copied* to the Trash and then marked for deletion in the Inbox.

This can easily be seen when accessing the mailbox with other mail clients
(messages are crosslined). This behavior is by design, though I for one, don't
find this design very user-friendly. To discuss this, head over to Bug 220064.

Prog.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.