Crash when attempting to install an incompatible theme.

RESOLVED DUPLICATE of bug 269076

Status

--
critical
RESOLVED DUPLICATE of bug 269076
14 years ago
14 years ago

People

(Reporter: trix, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Tbird crashes when trying to install an incompatible theme in latest linux build.

TALKBACK INCIDENT ID#: TB1871475Y

Steps:
1. Install latest linux build 20041110.
2. Bring up Themes dialog and install an incompatible theme (ie:
nauticalTb.0.4.0.jar)

Results:
Crash

Note:
Win32 and Mac builds correctly prompt users that the theme is incompatible.
(Assignee)

Comment 1

14 years ago
the statck doesn't make much sense...crashing in some glib library:

event_processor_callback() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 67]
libglib-2.0.so.0 + 0x4979f (0x004ca79f)
libglib-2.0.so.0 + 0x241e2 (0x004a51e2)
libglib-2.0.so.0 + 0x252d8 (0x004a62d8)
libglib-2.0.so.0 + 0x25610 (0x004a6610)
libglib-2.0.so.0 + 0x25c53 (0x004a6c53)
libgtk-x11-2.0.so.0 + 0x10eff3 (0x04416ff3)
nsAppShell::Run() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/mail/app/nsMailApp.cpp,
line 59]
(Assignee)

Comment 2

14 years ago
this is a dupe of your extension bug. same crash.

*** This bug has been marked as a duplicate of 269076 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.