If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Exception from onChange method for INPUT type="text" field that calls JS alert()

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: bcombee, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

On the linked page, if you enter text into the field and hit enter, you'll get
an exception message on the Javascript Console, and after you dismiss the alert,
the form is reset.



Reproducible: Always
Steps to Reproduce:
1. Go to the page http://combee.net/bugs/moz_bug_1.html
2. enter "test" into the box and hit enter

Actual Results:  
alert appears with "tset", form is reset back to default values, exception
report in JS console

Expected Results:  
alert should appear with "tset", nothing should crash or get reset

This is the error message on my system:

Error: [Exception... "'Permission denied to get property
XULElement.selectedIndex' when calling method:
[nsIAutoCompletePopup::selectedIndex]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
http://combee.net/bugs/moz_bug_1.html :: updateOutput :: line 17"  data: no]
Source File: http://combee.net/bugs/moz_bug_1.html
Line: 17

Comment 1

13 years ago
Works for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0. Maybe try upgrading to latest release?

Comment 2

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050406
Firefox/1.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.