links refering to Microsoft Word files in network drive do not work, error msg: "is not a registered protocol"

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: merja, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Link refering to a Microsoft Word document in a network drive doesn't open.
Instead I get a blank browser page and message box with text "p is not a
registered protocol", where p is the letter connected to the network drive. Here
is the accurate link location copied: "p:\_Dokumentteja\museoinfo\Nimikkeen
muutokset yt-kokoukseen 11.04.doc" (Source: <a target="_blank"
href="P:\_Dokumentteja\museoinfo\Nimikkeen muutokset yt-kokoukseen
11.04.doc">P:\_Dokumentteja\museoinfo\Nimikkeen muutokset yt-kokoukseen
11.04.doc</a>)

Link works in Internet Explorer

Reproducible: Always
Steps to Reproduce:
1. Click the link
2.
3.

Actual Results:  
Message box with text "p is not a registered protocol", where p is the letter
connected to the network drive.

Expected Results:  
Open the requested Microsoft Word document.

Comment 1

13 years ago
You should use the file:/// syntax for file links.
"p:\_Dokumentteja\museoinfo\Nimikkeenmuutokset yt-kokoukseen 11.04.doc" is no
valid URL. a) no protocol given b) a backslash "\" is invalid in an URL

"file:///P:/_Dokumentteja/museoinfo/Nimikkeenmuutokset yt-kokoukseen 11.04.doc"
would be a correct URL.
Additional note: you can't open file:// links in documents which are loaded from
http:// because of security restrictions.

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
*** Bug 274196 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.