a minor change in how pasting URLS works that will be very beneficial

RESOLVED DUPLICATE of bug 23485

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 23485
14 years ago
14 years ago

People

(Reporter: Geoff Woodcock, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Often, as a result of unintended formatting changes in a document, a URL is
emailed or otherwise sent to me that is broken into two lines separated by a
carriage return. When the URL is copied and pasted into FireFox, only the
portion before the carriage return seems to make it into the box. This forces me
to manually reassemble the URL before pasting it into the browser, which is a
pain. If CR/LF is illegal in the URL, could not the entire string be accepted,
and the offending characters parsed out?


Reproducible: Always
Steps to Reproduce:
1. take a URL
2. paste it into notepad
3. insert a CR, breaking the URL into 2 lines
4. select all the text and paste it into the URL box in Firefox

Actual Results:  
(see details)

Expected Results:  
(see details)
See bug 23485 for the unending discussion of why it's the way it is on various
platforms, and bug 50935 comment 5 for the hidden pref workaround so that you
can paste multiline URLs (and multiline anything in any singleline text field)
in Windows.

*** This bug has been marked as a duplicate of 23485 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.