Search panel does not open for Search results

VERIFIED WORKSFORME

Status

SeaMonkey
Search
P1
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: johng, Assigned: Steve Lamm)

Tracking

Trunk
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] w/b minus on 03/03, URL)

(Reporter)

Description

18 years ago
When you get search results, the Sidebar is supposed to open to the Search panel
and display the search results.

With today's build (02-07, #2000020108), I can't make this work for any site
including Netcenter.  Something is off with Robert's beta 1 hack.
(Reporter)

Comment 1

18 years ago
marking M14 and nominating for beta1.  This used to work and is the basis of our
persistent search story.
Keywords: beta1
Target Milestone: M14
(Reporter)

Comment 2

18 years ago
Note that this is similar but different than bug 24034.  24034 refers to the
fact that we don't have all the necessary Sherlock files to work all the time.
In this case, persistent results *never* work even when we do have the Sherlock
files.  So we have *no* persistent search results.
Blocks: 24034

Comment 3

18 years ago
Steve, I haven't changed any part of my hack in a while. Can you check and see 
if the sidebar has changed in such a way to break this again?  Thanks!
Assignee: rjc → slamm

Updated

18 years ago
Priority: P3 → P1

Updated

18 years ago
Whiteboard: [PDT+]
(Assignee)

Comment 4

18 years ago
Guessing I can finish this by 2/15/00 (after my other PDT+ bugs).
Marking assigned.
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 2/15/00
(Assignee)

Comment 5

18 years ago
I tried this in my Linux build today and it works fine. If the sidebar is 
collapsed, it opens it. If the sidebar is on a different panel, it selects the 
search panel.

Marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Regression, re-opening bug.

No longer works for me - especially first try on Netscape Search if Sidebar is 
already closed.  Could not get it to work in today's usability studies - Feb 
28th build on Win.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
I'm not sure I'd hold beta for this.  The search results are there, right?  The
panel just doesn't open automatically.  I'm removing the pdt+.
Whiteboard: [PDT+] 2/15/00 → 2/15/00

Updated

18 years ago
Whiteboard: 2/15/00 → [PDT+] w/b minus on 03/03

Comment 8

18 years ago
Putting on PDT+ radar for beta1.  But will move to PDT- if not fixed by 03/03 or 
regression occurs.
(Reporter)

Comment 9

18 years ago
cc'ing Robert - I know that Robert hasn't changed this code for awhile, but from 
the very first days it was put in it only worked some of the time, and that 
still is the case today.  So there might be something to fix in Robert's code 
(but what do I know?).

This should work all the time for Netscape Search, ideally would also work for 
AOL Search and the other engines we are shipping, but let's be sure that at 
least the default works for beta1.
Thanks for the vote of confidence there, John.

Before you say "from the very first days it was put in it only worked some of 
the time", perhaps it would be good for you to actually know how it works. I've 
told you this before, but perhaps you've forgotten.

The hack works by only opening up the sidebar if the URL being loaded in is a 
HTTP GET, and we have an exact URL match via one of the Sherlock files.

The reason why you didn't always see the hack work for Netcenter searches was 
due to some Netcenter searches actually redirecting to "google.netscape.com" for 
which we've never had a Sherlock file.

If you can find a case where doing a search with a URL which directly matches 
one of the installed Sherlock files doesn't work, let me know.
(Assignee)

Comment 11

18 years ago
This feature worked ok for me today. Bill Law volunteered to try this out on his
machine at home tonight.

Can you give me cases where this is not working where it should?

Comment 12

18 years ago
Works for me, even when my results came from Google.  I did see some problems 
with sidebar not repainting, though.
(Assignee)

Comment 13

18 years ago
Marking WORKSFORME.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 14

18 years ago
marking verified. there is another bug with a specific case/url referenced where the sidebar does not open. all future bugs of this 
type should be specific like that.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.