Ctrl+W does not always close tab

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Timwi, Assigned: Aaron Leventhal)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/0.9.2 StumbleUpon/1.998
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/0.9.2 StumbleUpon/1.998

In Firefox 0.9 it seems that I could always close the current tab by pressing
Ctrl+W.

In Firefox 1.0, after I have just opened a new tab by pressing Ctrl+Enter on a
link, it seems that I have to press Ctrl+W twice in order to close the tab if I
want to close it before the page loads.

Reproducible: Always
Steps to Reproduce:
1. Find a webpage.
2. Use Find As You Type to navigate to a random link, preferably one that will
be slow to load.
3. Press Ctrl+Enter.
4. Press Ctrl+W before page loads.
Actual Results:  
Nothing happens.

Expected Results:  
Tab should close.
(Assignee)

Comment 1

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041220
Firefox/1.0+

Please reopen if it's still a problem in the trunk.
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/

This could be a duplicate of 249136, if you have new links opening in the
foreground.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Disability Access → Keyboard Navigation
Keywords: access
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.