crash after general.useragent.vendorComment change

VERIFIED DUPLICATE of bug 83376

Status

defect
--
critical
VERIFIED DUPLICATE of bug 83376
15 years ago
a year ago

People

(Reporter: ufoonline, Assigned: yuanyi21)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I don't have tested completed but:
If you set general.useragent.vendorComment to:
someword - http://www.yoursite.com - http://www.yoursite2.com

The browser don't start after the restart.

Reproducible: Always
Steps to Reproduce:
1. open about:config
2. modify\create general.useragent.vendorComment 
3. Set general.useragent.vendorComment to: something - http://www.website.com - 
http://www.website2.com

Actual Results:  
Browser crash after the restart

Expected Results:  
Normal startup, opening firefox navigation window

Application Information

 Application Launch Time
   12/11/2004 1.20

 Build Identifier
   2004110711

 Deployment Identifier
   MozillaOrgFirefox10Win322004110711

 Interface Version
            8 (0x00000008)

 Monitor Configuration Version
            3 (0x00000003)

 Platform Identifier
   Win32

 Product Identifier
   Firefox10

 Talkback Configuration Version
            3 (0x00000003)

 Talkback Library Version
            7 (0x00000007)

 Vendor Identifier
   MozillaOrg

Runtime Information

 Active Application
         1388 (0x0000056C)

 Command Line
   "C:\Programmi\Mozilla Firefox\firefox.exe" 

 Contents of the Stack

[   0] 18 00 00 00 08 00 00 00 F8 FF 12 00 08 00 00 00 [................]
[  10] 40 2C 8A 00 00 00 00 00                         [@,......]

 Current User Name
   ufoonline

 Processor Exception
   3221225477 (0xC0000005)
Reporter

Comment 1

15 years ago
I have done a test, and this is the response:
general.useragent.vendorComment can contenent max 39 character

If you insert more than 39 char, the browser crash at the startup.
39 chars sounds suspiciously like the nsAutoString buffer.. but I don't see any
obvious problems with the way  we get vendorComment from prefs and no other
places in the code touch it...

Reporter, do you have a talkback incident id for the crash?
Reporter

Comment 3

15 years ago
Posted file Crash information
please don't attach the saved TalkBack Data (useless....).
We need the Talkback ID from that crash. You can see the ID if you open
Talkback.exe after you sent a crash report !
Reporter

Comment 5

15 years ago
Thank you  Matti!

The talkback id: TB1890546K
crashes in java land... sounds like a bug in the plugin to me.
Assignee: general → kyle.yuan
Component: Browser-General → Java: OJI
QA Contact: general
Reporter: Which Java Version do you use and does it work if you remove the java
plugin temporary ? (see "about:plugins" as URL)
Reporter

Comment 8

15 years ago
(In reply to comment #7)
> Reporter: Which Java Version do you use and does it work if you remove the java
> plugin temporary ? (see "about:plugins" as URL)
I have Java: Plug-in 1.4.2_05 for Netscape Navigator (DLL Helper)

If I disable the java plugin, firefox don't crash and work normally.
one last thing: Can you try JRE 1.5 ?
http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-1.5.0-oth-JPR&SiteId=JSC&TransactionId=noreg
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Reporter

Comment 10

15 years ago
(In reply to comment #9)
> one last thing: Can you try JRE 1.5 ?
>
http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-1.5.0-oth-JPR&SiteId=JSC&TransactionId=noreg
> 

Crash always with jre 1.5 (Java Plug-in 1.5.0 for Netscape Navigator (DLL Helper))

Assignee

Comment 11

15 years ago
The code in java plugin used for parsing useragent string is far away from
robust. So any hacking on the ua string may cause java plugin crash.

*** This bug has been marked as a duplicate of 83376 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.