program goes into a warn loop when trying get new mail on server that only allows requests every XX minutes

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Doug Williams, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

My mail server only allows you to send your request for new mail every 2
minutes.  If i press the "get mail" button anytime within this two minute
period, Thunderbird warns me as it should, however after I press OK on that
warning, it just warns me again, and again, indefinately.  I then ctrl+alt+del
out of the program.

Reproducible: Always
Steps to Reproduce:
1. Get new mail
2. Try and get new mail within the amount of time your server does not take
request from your password
3.

Actual Results:  
The warning about time comes up, you click OK, and the warning comes back up,
over and over ....

Expected Results:  
Warned you once, then just stopped warning you.

Comment 1

14 years ago
can we get a pop3 protocol log?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html

Comment 2

14 years ago
I don't already have the log, but I guess it's the normal password-failed-thing
that's going on.
Without a server supporting the extended response codes we assume the login
failed because of wrong credentials. But because of bad experience in the past
we don't go and forget the password if the user has successfully authenticated
at least once in this session. See e.g. bug 249920 and bug 249240 for the problem.

To repeat what I've written in the last named bug:
I guess the best solution would be modifying this further. Either by giving the
user the chance to stop authentication (via Cancel in the alert, I think this is
bug 189633) or automatically do this after say three failed tries without
discarding the password.

David, since also after putting more intelligence into recognizing what's going
on and trying to avoid false discards there are still enough problems, we
should'd really consider above task(s).

Comment 3

14 years ago
Christian, I agree - I'd even go so far as to say that we could do both - add a
cancel button, and limit the attempts (though maybe 5 instead of 3)

Comment 4

14 years ago
I've also experienced this, although the account has long been abandoned to
spam. I could temporarily resurrect it if you still want a log.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general

Comment 5

10 years ago
David, Christian, is a new bug needed?

reporter didn't close the bug - from '06 "I am now using 1.5.0.7 (was using 1.0.7 I believe when I saw that bug) and I do not see the problem anymore."

=> WFM per reporter
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.