Cannot dismiss pop-up alert when mail check fails due to a server time limit error

RESOLVED DUPLICATE of bug 189633

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 189633
14 years ago
14 years ago

People

(Reporter: Jennifer Mullen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I use a mail server which does not allow checking for mail more frequently than
every 120 seconds. If I attempt to check mail before 120 seconds has passed
since my last mail check, Thunderbird displays a pop-up alert that states:
"Sending of password did not succeed. Mail server email.psu.edu responded:
<userid> must wait <seconds> seconds before checking mail again."

This alert has one button: "OK". When "OK" is pressed, Thunderbird immediately
attempts to check mail again, fails again, and displays the alert. The result is
a loop in which the alert cannot be dismissed until enough time has passed for a
mail check to succeed. Thunderbird is completely unusable during this time period.

The same happens if I attempt to dismiss the dialog box using "esc".

The obvious answer is "don't do that", but it's easy to trigger this behavior
accidentally.


Reproducible: Always
Steps to Reproduce:
1. Check mail on a POP server that has a restriction on how often a user can
check mail.
2. Attempt to check mail before enough time has passed since the last mail check.
3. Attempt to dismiss the alert that pops up.

Actual Results:  
An alert was displayed which could not be dismissed until enough time passed for
the POP server to allow a mail check.

Expected Results:  
The user should be presented with the option to continue OR CANCEL the mail check.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 189633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.