Failure to load local documents with certain characters in the path ex: ' ²'

RESOLVED DUPLICATE of bug 263570

Status

()

--
major
RESOLVED DUPLICATE of bug 263570
14 years ago
14 years ago

People

(Reporter: kfitzner, Assigned: bugs)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If Firefox is not running, and a data file associated with it is double-clicked,
then it will load properly every time.  If Firefox is running already and an
associated data file is double-clicked, if that file has the "squared" character
in the name: '²', then an error dialog is displayed saying: "The file
/l:/path/to%B2/file.htm cannot be found.  Please check the location and try again."


Reproducible: Always
Steps to Reproduce:
1. Create a directory, the name of which has the character made by holding down
the alt key and typing the zero-one-seven-eight keys on the numeric keypad.  You
should get a "squared" symbol - a superscript 2: '²'
2. Place an html file in that directory
3. Start an instance of Firefox
4. Double click the html file you placed in the directory.

Actual Results:  
An error dialog is displayed saying: "The file /l:/path/to%B2/file.xml cannot be
found.  Please check the location and try again."

Expected Results:  
Load and display the file.
(Reporter)

Comment 1

14 years ago
Not sure if this was "file handling" or "os integration".
Version: unspecified → 1.0 Branch

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 263570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.