Crash on quitting when I read mail not marked as read

RESOLVED DUPLICATE of bug 268681

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 268681
13 years ago
13 years ago

People

(Reporter: Jean-Marc, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: version 0.9+ (20041109)

(I have 5 POP3 accounts, with 4 of them in the global inbox. I un-selected RSS
and offline support at setup. I don't have any theme or extension.)
When I read a mail marked as unread - either a true new mail OR an old mail
re-flagged as unread - there's a crash when I quit. No harm done, but a crash
nonetheless.

Reproducible: Always
Steps to Reproduce:
1. Start TB (latest 0.9+ trunk version like me)
2. Get new mail and have the chance to receive one *or* mark an old mail as unread
3. Read it (can be a text-only simplistic mail)
4. Quit TB

Actual Results:  
Crash.

Expected Results:  
Exit gracefully.

- Sent the Talkback report TB1899313Z.
Note : I read the ID in
%APPDATA%\Talkback\MozillaOrg\
 Thunderbird10\Win32\20041109\
  info.db
I hope I'm right, maybe there's a more obvious way to know it but then tell me ...

- There's no d*a*t*a***l*o*s*s, so no worry here.
- This happens in the global inbox account and in other accounts as well.
(Reporter)

Comment 1

13 years ago
(Tweaking the summary)
Summary: Crash on quitting when I read mail marked as new → Crash on quitting when I read mail not markedflagged as read
(Reporter)

Comment 2

13 years ago
(Re-tweaking. My fingers went wrong. Sorry for bug spam.)
Summary: Crash on quitting when I read mail not markedflagged as read → Crash on quitting when I read mail not marked as read
(Reporter)

Comment 3

13 years ago
Mistake : this bug concerns the latest-0.9 version, not the trunk one.
(Reporter)

Comment 4

13 years ago
Actually ... if I ever read any mail it crashes every time when I quit now !  
:-(   But I won't change the summary. Maybe the behaviour changed after I
compacted the folders, maybe not ... I'm at your disposal to send other Talkback
reports, or check something else.
I've yet to test whether reverting to the 0.9 release fixes the problem. But I
lack time right now.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> I've yet to test whether reverting to the 0.9 release fixes the problem. But I
> lack time right now.

(Answering to myself) Yes it does. Release is fine. 0.9+ (latest-0.9) is not.

Comment 6

13 years ago
can you try today's build? I did fix a crash on exit yesterday (or the day
before, actually) - I can't get to talkback to see if the stack traces are the same.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> can you try today's build? I did fix a crash on exit yesterday (or the day
> before, actually) - I can't get to talkback to see if the stack traces are the
same.

I did - version 0.9+ (20041111). No crash anymore ! Thanks a lot. WORKSFORME at
the very least !

Comment 8

13 years ago

*** This bug has been marked as a duplicate of 268681 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.