l10n zh-CN add zh-CN help and inspector into the localized builds

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: shaohua.wen, Assigned: shaohua.wen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.7.5) Gecko/20041107 Firefox/1.0

I just patched the defines.inc and added help & inspector resources.
the help & inspector directory is already in the cvs repository for a long time
but I don't know howto add it to the builds.
So here I request for adding them into the 1.0 builds

Reproducible: Always
Steps to Reproduce:
(Assignee)

Updated

14 years ago
Flags: blocking-aviary1.0-L10N?
(Assignee)

Comment 1

14 years ago
Created attachment 165682 [details] [diff] [review]
patch of defines.inc
(Assignee)

Updated

14 years ago
Summary: add zh-CN help and inspector into the localized builds → l10n zh-CN add zh-CN help and inspector into the localized builds
(Assignee)

Updated

14 years ago
Attachment #165682 - Flags: approval-aviary?

Comment 2

14 years ago
you need to add the files to extra-jar.mn.
See
http://lxr.mozilla.org/l10n-aviarybranch/source/browser/locales/de-DE/extra-jar.mn
for an example.

Where the actual files part of the approved original package or when did they 
land?
Assignee: firefox → Shaohua.Wen
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Attachment #165682 - Flags: review-
Attachment #165682 - Flags: approval-aviary?
Attachment #165682 - Flags: approval-aviary-
(Assignee)

Comment 3

14 years ago
Created attachment 165710 [details] [diff] [review]
patch for zh-CN directory
Attachment #165682 - Attachment is obsolete: true
(Assignee)

Comment 4

14 years ago
Comment on attachment 165710 [details] [diff] [review]
patch for zh-CN directory

Hi Axel,Please help to check the new patch.
Thanks a lot!
Attachment #165710 - Flags: approval-aviary?

Comment 5

14 years ago
Holy, do you intend to translate help for 1.0?
The one in the tree seems to be the english help, there is no need to package 
that, as it is included in the build by default.

If you do, I'd rather see you getting the help off the ground before including
it in the build.
If you don't, I suggest to cvs remove the english help contents.
(Assignee)

Comment 6

14 years ago
Hi Axel,
  The help content is in English,but the UI for the help window are localized.
  Because we don't have enough people to do the help translation,So I don't know
when can I commit the translated help files,but I would like to let the user see
the translated UI,instead of "Help Contents,For IE Users" in the menu.
Thanks&Regards,Holy
(Assignee)

Comment 7

14 years ago
Hi Axel,
  If there is any other way to keep the UI translated and use the english help
content,I agree to remove the untranslated help content and keep the translated
dtd and properties files.
  Thanks&Regards,Holy

Comment 8

14 years ago
Comment on attachment 165710 [details] [diff] [review]
patch for zh-CN directory

yeah, translating help viewer says to ship help, too, so r/a=me
Attachment #165710 - Flags: review+
Attachment #165710 - Flags: approval-aviary?
Attachment #165710 - Flags: approval-aviary+
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

14 years ago
Axel,Thank you very much!
(Assignee)

Comment 10

14 years ago
done cvs checkin.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Flags: blocking-aviary1.0-L10N?
You need to log in before you can comment on or make changes to this bug.