about:config should have a documentation what the prefs do

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
14 years ago
a year ago

People

(Reporter: u49640, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

about:config is great for power users, but its really hard to guess what and
option really does.

I think it needs a documentation (maybe in form of tooltips) where the reason
for this pref is explained and all possible options are listed
(or just put a link on top of the list to a webpage with details, but a real
help would be better)

btw: dont call the possible options 1,2,3,4 unless the mean exactly 1,2,3,4,... 
a Dropdown list with a short textual explaination would be much better. (you
could still save the numbers in prefs.js, but i dont have to guess everytime if
i wanted browser.link.open_newwindow.restriction set to 1,2 or 3 to get what i want)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
about:config is really just a convenience for power users and developers.  The
Preferential project tried to do this, but it was overwhelming.  This would also
be an undue burden on our localizers, since this is UI that isn't really
intended/needed for the vast majority of users.

This would never go into the core, but it could be useful as an extension, if
someone were to resurrect Preferential.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
*** Bug 286559 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences

Updated

12 years ago
Duplicate of this bug: 367881

Comment 5

12 years ago
See also bug 323502, which asks for about:config to include a link to a wiki page describing many of the prefs.

Comment 6

11 years ago
V/wontfix.

It would be too hard to put something into the code for every pref. The effort to document every pref is barely up to date, and the pref infrastructure docs (which I mostly wrote) are in bad shape as well.

For now, people need to be careful (use LXR and bugzilla!) or (even better) contribute to the docs, or work with developers as they code features and fix bugs. That's what I do.
Status: RESOLVED → VERIFIED
QA Contact: preferences → benc
QA Contact: benc → preferences
Duplicate of this bug: 767834
Duplicate of this bug: 195845
Duplicate of this bug: 852124

Comment 10

2 years ago
Even though this would probably be a lot of work, in my opinion it is really unacceptable to provide so many cryptic options with no proper documentation. How are people meant to use them if doesn't say anywhere what they actually do?

Comment 11

a year ago
I'm not a power user. I'm a disabled user trying to deal with accessibility problems. Advice for disabled users often requires changing about:config settings, adding extensions, and writing our own user styles...
You need to log in before you can comment on or make changes to this bug.