cathaypacific.com - rejects non-Firefox Gecko browsers

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: mark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When attempting to use this website to search for flight fares and availability
the following message is returned.

"Your browser version is not fully supported by our site. This site can be best
viewed with IE5.5 (and above) and Netscape 7.1(and above). You may download the
latest version."

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.cathaypacific.com/
2. Pick some flight options in the "Schedules and Fares" form
3. Click "Show Fares and Availability"

Actual Results:  
A new full screen window opens with the message:

"Your browser version is not fully supported by our site. This site can be best
viewed with IE5.5 (and above) and Netscape 7.1(and above). You may download the
latest version."

and links to the download sites for Internet Explorer and Netscape.

Expected Results:  
Returned fare and availability information for the selected flights.
(Reporter)

Comment 1

15 years ago
Sent email to dns_admin@cathaypacific.com reporting bug.

Comment 2

14 years ago
It seems to work okay for me now.

Comment 3

14 years ago
thanks crf
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
It stopped working again with SeaMonkey.
http://www.cathaypacific.com/xmlibe2/DownLoad.jsp is displayed if I try to check fares and availability.

Should this bug be reopened or a new bug be filed?

Comment 5

12 years ago
Please reopen and contact the site and ask them what happened. Probably a new person who isn't up to speed on cross browser development. Funnily, Firefox with a spoofed Seamonkey ua worked but Seamonkey didn't. :-)
Reopening, still busted for SeaMonkey
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Works great if you put "firefox" in the UA string. Totally broken otherwise.
Blocks: 334967
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: cathaypacific.com - does not allow Mozilla → cathaypacific.com - rejects non-Firefox Gecko browsers

Comment 8

10 years ago
What are the steps to reproduce? Even with "Firefox" in the user agent string the search form always comes back eventually.
Looks like this one might be FIXED. I definitely had problems when I made comment 7, but I can't reproduce them now, and the URL in comment 4 no longer exists.
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.