Offline mode not saved if true and randomly written as false

RESOLVED DUPLICATE of bug 240898

Status

()

RESOLVED DUPLICATE of bug 240898
14 years ago
5 years ago

People

(Reporter: blh, Assigned: darin.moz)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.3) Gecko/20040910

On a completely random basis, Mozilla (mail and browser) comes up as Offline (I
never work offline).  Checking prefs, I note that network.online is NEVER
written if it is true.  It appears that it will randomly write network.online as
false, regardless of what its previous status was.  

If I edit prefs.js with a network.online variable set to "true" it doesn't seem
to make any difference.  Once Mozilla is closed, the network.online line no
longer exists in prefs.js

If the browser writes a network.online, false statement, it will keep it for a
time (again random), but doesn't always come up offline.

It almost seems that the network.online value is not even being read and that
the internal value for online is coming up randomly because its effectively an
unitialized variable.

This is similar to other offline bugs, but they all seem to be reported for Mac,
not PC.

Reproducible: Sometimes
Steps to Reproduce:
1.  Add network.online, true to prefs
2.  Run browser and exit
3.  network.online will usually not exist (except on a random basis)

Actual Results:  
As I stated, the writing of network.online by the browser seems like a
completely random event.

Expected Results:  
It should be storing the online state and using that value when it the browser
is restarted.

Comment 1

14 years ago
Your build is more than 2 months old, could you retry with a newer nightly build?
Whiteboard: DUPEME
(Reporter)

Comment 3

14 years ago
(In reply to comment #1)
> Your build is more than 2 months old, could you retry with a newer nightly build?

Using this build:
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8a5) Gecko/20041115

If I set Mozilla offline, I see that network.online is set to false and stays
set to false.

If I then set Mozilla to online, network.online is not written to prefs.js at all.

If I edit prefs.js and add network.online to true, it still isn't written on exit.

I haven't been able to duplicate the random switch to offline mode, but since
this is a random event, it's difficult to determine whether it just hasn't
happened yet.
(Reporter)

Comment 4

14 years ago
Further information in testing build:
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8a5) Gecko/20041115

When entering and exiting the same profile (that is starting Mozilla with
Profile A, exiting and then restarting Mozilla which automatically runs profile
A), the results are as described previously.

A different and more annoying symptom has appeared. If I switch profiles after
having launched Mozilla, the new profile ALWAYS comes up as offline, regardless
of what its previous state was.  When coming up offline, again network.online is
set to false.  network.online is never set to true when changed to online within
the GUI.

BTW, this was not a problem in Mozilla release 1.4.1.2.
> Checking prefs, I note that network.online is NEVER written if it is true. 

That's because "true" is the default value.  Prefs whose values are equal to the
default aren't saved to prefs.js.

So the behavior of writing the value if and only if it's "false" is correct...

If the offline state is not read correctly at startup, that's a bug, but the
behavior you described should not lead to that.
(Reporter)

Comment 6

14 years ago
Ok, that makes sense.

Here is the current behavior:

If I enter and exit Mozilla using Profile A, then network.online reflects the
proper status upon the exit and all is well.

If I start Mozilla using Profile A and then switch profiles to Profile B (using
the Tools|Switch Profiles menu), I see that network.online for Profile A is
written as false even with Profile A being online upon exit.
Ah, ok.  That was just fixed a week ago...

*** This bug has been marked as a duplicate of 240898 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.