Closed Bug 269495 Opened 16 years ago Closed 16 years ago

Newlines in title attributes render as garbage

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 67127

People

(Reporter: rosser, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Newlines embedded in tags' title="blah, blah, blah" attributes render as garbage
characters. This is reproducible in Firefox/0.9 (Linux), Firefox/1.0PR (Linux)
and Firefox/1.0 (Win32).

Reproducible: Always
Steps to Reproduce:
1. http://qualia.org/linebreak.html
2. Mouse over the links.
3. View source.

Actual Results:  
The newline characters render either untranslated, in the case of \n, or as
garbage characters in the case of either/both of 

.

Expected Results:  
Rendered multi-line tooltips.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.