Views persist for regular folders, but not for virtual folders

VERIFIED FIXED in Thunderbird1.0

Status

VERIFIED FIXED
14 years ago
6 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

unspecified
Thunderbird1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: see comment 5 for relnote content)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
tested with 200411120x-0.9 bits: marcia sees this on mac, asa on windows and me
on linux. Views persist for regular folders, but not virtual folders.

test case
---------
1. I've set the View for some of my regular (non-virtual) folders, eg:

Inbox - View: Has attachments
bugscrub - View: Last 5 days

2. when I switch btwn these regular folders, the View I had selected does
persist --as expected.

3. go to a virtual folder: in my case I went to a virtual folder containing a
couple unread and read messages.

4. in the virtual folder change the View from All to Unread. as expected, only
the Unread messages displayed.

5. click on another folder to view --it doesn't matter if it's a regular folder,
or a virtual folder.

6. click back on the virtual folder in step 4.

results: the View set in the virtual folder does not persist. the View of the
virtual folder, oddly, becomes whatever was set for the folder clicked in step 5
*but* that state is actually ignored and all items in the virtual folder are
displayed.
(Reporter)

Comment 1

14 years ago
nominating for 1.0.

what should the expected behavior be? should it be the same as regular folders
and keep (persist) its last-set View? or should a view just revert to All for
virtual folders (if the former is more difficult to implement), since that's
what seems to be actually occurring?
Target Milestone: --- → Thunderbird1.0
(Assignee)

Comment 2

14 years ago
Created attachment 165869 [details] [diff] [review]
the fix

this fixes it for the single folder virtual folders. 

We won't be implementing this for searches across multiple folders.
(Assignee)

Updated

14 years ago
Attachment #165869 - Flags: superreview?(bienvenu)

Updated

14 years ago
Attachment #165869 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 3

14 years ago
fixed branch and trunk
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

14 years ago
(In reply to comment #2)
> We won't be implementing this for searches across multiple folders. 

just to clarify, do you mean that Views won't persist with subfolders within
virtual folders --or something else?
(Assignee)

Comment 5

14 years ago
We won't be implementing this for searches across multiple folders. 

means virtual folders that search more than one folder will  not support
remembering views.

Comment 6

14 years ago
(In reply to comment #5)
> We won't be implementing this for searches across multiple folders. 
> 
> means virtual folders that search more than one folder will  not support
> remembering views.

Ahem.. isn't searching multiple folders supposed to account for 90% of the cases
where virtual folders would be used?  As I see this feature, people would use
virtual folders to consolidate and search through multiple folders, rather than
just filtering just one of them (which in most cases is actually achievable
using the views panel, or the quick search box).

Not a very constructive comment, I know, and I have no intention of starting a
flame war on this, but seeing a lot of other users' opinions, I think the above
would make some sense.  Better leave a feature out (it's not critical anyway),
than doing a partial implementation that is not very easy to explain and has a
high potential of getting people confused.
(Reporter)

Updated

14 years ago
Keywords: relnote
Whiteboard: see comment 5 for relnote content
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> As I see this feature, people would use
> virtual folders to consolidate and search through multiple folders, rather than
> just filtering just one of them (which in most cases is actually achievable
> using the views panel, or the quick search box).

if this won't be implemented for tbird 1.0, I think this would be worthy of an
RFE in a post-1.0 release.
(Reporter)

Comment 8

14 years ago
vrfy'd fixed with 2004120x-0.9 on linux and mac.

spun off bug 272684 to request persistent Views for saved searches based on
multiple folders.
Status: RESOLVED → VERIFIED
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.