If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When clicking on link that opens new window, the window is set to a width that is too small to view content and does not allow you to resize. It seems to be happening on sites that have links set with a specific width / height popup.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Joey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When you click on the top survivor video link on the right hand side of the page
at http://www.cbs.com , the popup open in a window that is about 250 pixels wide
and it you are not able to stretch the window. I am forced to use Mozilla or IE
to view pages with popups because of this.

Reproducible: Always
Steps to Reproduce:
1. http://www.cbs.com/
2. click on any of the video links marked with a video camera icon
3.

Actual Results:  
The popup does not load up with its full size and you are not able to stretch
the browser window to rectify this.

Expected Results:  
It should have opened the popup at the set width that the html calls for or give
you the option to stretch the window out.

Comment 1

13 years ago
same happens with Mozilla Suite on Win2000

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511
Summary: When clicking on link that opens new window, the window is set to a width that is too small to view content and does not allow you to resize. It seems to be happening on sites that have links set with a specific width / height popup. → When clicking on link that opens new window, the window is set to a width that is too small to view content and does not allow you to resize. It seems to be happening on sites that have links set with a specific width / height popup.

Comment 2

12 years ago
(In reply to comment #1)
> same happens with Mozilla Suite on Win2000
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511

It seems that this is an issue of the Window Manager (Windows). This thing
doesn't happen in Linux.

Comment 3

12 years ago
Created attachment 209342 [details]
prefs.js file causing problems with Firefox 1.5 om Windows XP. see "help" button at wsj.com

This profile is I think responsible for the problem since I don;t have the problem with a new profile.

Updated

12 years ago
Attachment #209342 - Attachment description: prefs.js file causing problems → prefs.js file causing problems with Firefox 1.5 om Windows XP. see "help" button at wsj.com

Comment 4

12 years ago
(In reply to comment #3)
> Created an attachment (id=209342) [edit]
> prefs.js file causing problems 
> 
> This profile is I think responsible for the problem since I don;t have the
> problem with a new profile. 
> 
A new profile does fix the problem in some cases (such as settings for video news on news.bbc.co.uk) but doesn't in others: In Yahoo! Mail Beta, click 'compose', then 'attach'. The attachment popup is clipped hiding the 'cancel' button. Indeed the problem doesn't occur in Linux.
Assignee: bross2 → nobody

Comment 5

11 years ago
on rogers (canada); i have noticed that if i reduce the browser to window mode, and then open the video news link (yahoo) the window is still cropped  but resizing option is now available.  also, the initiating window may return to full screen and the new window will remain functional until closed.  this behaviour seems to be exclusive to firefox as it does not occur on ms inet exploder.
Marvin, what specific site did you see this on? Can you give full steps to reproduce? (Such as, go to [URL], click this specific link, etc.)

Comment 7

11 years ago
hi,

i access the videos via my isp home page
(rogers, which is in canada)
the url is "extreme.rogers.yahoo.com",
unfortunately you would have to have an account to login
in order to access the page

however after some thought,
i realized you may recreate this by going to:

    "news.yahoo.com"

click on any "video" link
and the behaviour should be:

full screen, no resizing options

window mode, resizing options available

hope this helps

thanx
;r 
This works for me using Firefox 2.0.0.3 on Windows XP and Mac OS X. I used the following steps to reproduce (which failed) based on comment 7:

1. Go to news.yahoo.com
2. Click the "Watch Video" link on the right hand side of the page

The window that popped up was the correct size; all content was visible. Additionally, there was no way to resize the window, which was something set in Javascript (I'm assuming) and there was no toolbar present.

Marvin, the bug you reported doesn't seem to reproduce for me. It also sounds different than what was reported in comment 0. Please check and see if you what your settings are in the Preferences -> Content -> Enable Javascript (Advanced). If you have the "Allow scripts to : Move or resize existing windows" or other such boxes checked, that could be causing a problem. If you can reproduce using Firefox 2.0.0.3 with a new profile and it's not expected behavior, per my paragraph above, please file a new bug.

http://kb.mozillazine.org/Profile_Manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.