TB09 crash on closing Thunderbird [@ ntdll.dll - nsMsgDatabase::`scalar deleting destructor']

RESOLVED DUPLICATE of bug 267575

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 267575
14 years ago
14 years ago

People

(Reporter: jay, Assigned: Scott MacGregor)

Tracking

({crash, topcrash+})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
This is clearly the #1 crash in Thunderbird 0.9.  Most user comments mention
closing TB in the Talkback data:

====================================================================================================
     Count   Offset    Real Signature
[ 35   ntdll.dll + 0x10f29 (0x7c910f29) f5ac6dea - nsMsgDatabase::`scalar
deleting destructor' ]
[ 23   ntdll.dll + 0x4c8e1 (0x77fcc8e1) 1c584490 - nsMsgDatabase::`scalar
deleting destructor' ]
[ 13   ntdll.dll + 0x33aed (0x77f83aed) 3867916d - nsMsgDatabase::`scalar
deleting destructor' ]
[ 11   ntdll.dll + 0x10f29 (0x7c920f29) 5eaa85a6 - nsMsgDatabase::`scalar
deleting destructor' ]
[ 6   ntdll.dll + 0x4c8e1 (0x778cc8e1) 148036a3 - nsMsgDatabase::`scalar
deleting destructor' ]
[ 5   ntdll.dll + 0x4c8e1 (0x784ac8e1) 6cc4c850 - nsMsgDatabase::`scalar
deleting destructor' ]
 
     Crash date range: 03-NOV-04 to 10-NOV-04
     Min/Max Seconds since last crash: 168 - 353707
     Min/Max Runtime: 243 - 363864
 
     Count   Platform List 
     59   Windows XP [Windows NT 5.1 build 2600] 
     34   Windows 2K [Windows NT 5.0 build 2195] 
 
     Count   Build Id List 
     93   2004110312
 
     No of Unique Users        87
 
 Stack trace(Frame) 

	 ntdll.dll + 0x10f29 (0x7c910f29)  
	 ntdll.dll + 0x10d5c (0x7c910d5c)  
	 msvcrt.dll + 0x1c2de (0x77c2c2de)  
	 nsMsgDatabase::`scalar deleting destructor'  
	 nsMsgDatabase::ForceClosed
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp
 line 1329] 
	 nsMailDatabase::ForceClosed
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/db/msgdb/src/nsMailDatabase.cpp
 line 107] 
	 nsGenericModule::Shutdown
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/glue/nsGenericFactory.cpp
 line 344]  
 
     (1844280)	Comments: trying to read mail
     (1841611)	Comments: Importing Address from Outlook
     (1816206)	Comments: Saved Search & Folder starting with same word  e.g.
"School List" and "School." Rename "School List" to "List." Close. Crash on close.
     (1806311)	Comments: Quitting
     (1799795)	Comments: Closing after creating virtuel folder
     (1785030)	Comments: Closing thunderbird.
     (1766409)	Comments: I added a virtual search folder  and had tried
unsuccessfully to add a button for delete junk from the buttons addon
     (1765362)	Comments: create an virtual folder and after that close tb
     (1763749)	Comments: Just installed 0.9  uninstalled themes that are not
valid  selected another theme  nothing happened so I closed Thunderbird. 
Feedback agent started.
     (1761158)	Comments: Thunderbird crashed at application exit after some
playing with NNTP account with trying to read undownloaded messages in offline mode.
     (1758250)	Comments: Quitting TBird Windows
     (1756253)	Comments: exiting via ctrl-q  
     (1751984)	Comments: Just installed QuickReply and AddressContext extensions
     (1749282)	Comments: Changed skin from standard to Nitpick 0.1.7.9;  clicked
"use this skin" (Theme verwenden) -> crash
     (1748500)	Comments: Closed Tb and it crashed again
     (1746299)	Comments: first shuting down the main window (exit thunderbird)
and then shuting down a opend mail
     (1743460)	Comments: Working with Saved Search
     (1738885)	Comments: I had been playing with virtual folders.  I created a
normal folder Local/Invox/Virtual to contain several virtual folders  I then
tried to create a virtual folder inside that container folder  but it gave me
error message "Folder exists" and dialog
     (1738885)	Comments:  stayed on screen.  If i closed the virtual folder
dialog  and opened a new window by doubleclicking my inbox the folder would be
there  but it's not a virtual one  it seems like it's an IMAP folder  it has tab
pages for quota's  permissions and offline
     (1738885)	Comments:  use.    I tried to delete all these test folders but
it didn't work  so i quit thunderbird and that's when it crashed
     (1735907)	Comments: Closing window.
     (1732001)	Comments: I had set up a saved search folder and was trying to
get it to display unread mail.  While playing around I had set the saved search
to customized but didn't pick anything. When going back to the properties the
folder name & search option fields were
     (1732001)	Comments:  blank. I reset the search options to status New. No
mail was showing up in the folder even tho I had new mail. I exited thunderbird
to see if a restart would show the mail and it crashed.
     (1730357)	Comments: closing TB
     (1727729)	Comments: 1. installed extension:
http://minimizetotray.mozdev.org/installation.html  2. clicked "X" button to
exit TB  3. crash  
     (1726916)	Comments: Again after closing TB 0.9 this crash  second time in a
row.  Brand new install into a separate folder
     (1725060)	Comments: First run of program after upgrading from 0.8 to 0.9. 
I played with 'search folders' and then closed the main window.  I saw that I
had a source dialog box still opened.  When I closed then it crashed.
     (1724807)	Comments: hit the close button
     (1723890)	Comments: crash after I exited Thunderbird
     (1721869)	Comments: I had been creating Saved Search Folders.  I kept
getting an (incorrect) error:  A Folder With the Specified Name Already Exists.
 I tried to move the parent folder so that it would be the child of a sibling. 
Same error.  I tried to exit Thunderbird  and
     (1721869)	Comments:  up came the Feedback Agent.
     (1721306)	Comments: closing thunder bird
     (1720514)	Comments: After switching theme from "Noia/Cute Ver 1.4.4 (Yop)"
to "Thunderbird (default)" Thunderbird crashes while restarting.
     (1719845)	Comments: Had just compacted my IMAP folder and then closed the
application when it crashed.  The IMAP account I had previously changed its
settings to use SSL as was restarting to ensure that it had applied the settings.
     (1718045)	Comments: Cloed TB0.9 after first start
     (1716280)	Comments: closing program after install update of jslib
     (1715284)	Comments: playing with Saved Search Folders  closing Thunderbird
 (also Saved Search didn't show Subject etc.)
 
====================================================================================================
     Count   Offset    Real Signature
[ 35   ntdll.dll + 0x10f29 (0x7c910f29) 1749b74a - ntdll.dll + 0x10f29
(0x7c910f29) ]
[ 14   ntdll.dll + 0x4c8e1 (0x77fcc8e1) 69c2ddf0 - ntdll.dll + 0x4c8e1
(0x77fcc8e1) ]
[ 12   ntdll.dll + 0x10f29 (0x7c920f29) 3af2271d - ntdll.dll + 0x10f29
(0x7c920f29) ]
[ 11   ntdll.dll + 0x3426d (0x7c93426d) 4110355d - ntdll.dll + 0x3426d
(0x7c93426d) ]
[ 7   ntdll.dll + 0x33aed (0x77f83aed) 418e3206 - ntdll.dll + 0x33aed (0x77f83aed) ]
[ 5   ntdll.dll + 0x11e58 (0x7c911e58) 9b4ce451 - ntdll.dll + 0x11e58 (0x7c911e58) ]
[ 5   ntdll.dll + 0x10f2b (0x7c910f2b) 79b28103 - ntdll.dll + 0x10f2b (0x7c910f2b) ]
[ 4   ntdll.dll + 0x33aed (0x77f73aed) 14d9626c - ntdll.dll + 0x33aed (0x77f73aed) ]
 
     Crash date range: 04-NOV-04 to 10-NOV-04
     Min/Max Seconds since last crash: 4 - 449520
     Min/Max Runtime: 96 - 449520
 
     Count   Platform List 
     79   Windows XP [Windows NT 5.1 build 2600] 
     14   Windows 2K [Windows NT 5.0 build 2195] 
 
     Count   Build Id List 
     93   2004110312
 
     No of Unique Users        81
 
 Stack trace(Frame) 

	 ntdll.dll + 0x10f29 (0x7c910f29)  
	 ntdll.dll + 0x10d5c (0x7c910d5c)  
	 msvcrt.dll + 0x1c2de (0x77c2c2de)   
 
     (1847871)	Comments: Closing the program
     (1842985)	Comments: Installing it.  I never got to any menus where I would
have entered my email information.  It just crashed.
     (1840344)	Comments: Importing mail from Outlook 2000
     (1819284)	Comments: Uninstalled TB 0.7 and installed the TB 0.9 release. 
Had TB open in the background for perhaps an hour  running the profile created
with TB 0.7.  Previously created Saved Search.  Closed TB and it crashed.   
Firefox 1.0 RC2 was also open at the time of
     (1819284)	Comments:  the crash.    
     (1811919)	Comments: Closed Thunderbird application
     (1811142)	Comments: Closing application
     (1802169)	Comments: Closing (CTRL+Q)
     (1793235)	Comments: AntiVir just found a virus in the trash-folder; I told
it  to move the file into carantaine :-( ....
     (1786898)	Comments: Hmm.. It seems to crash every time I change some
settings... This time I changed to threaded and then to grouped view
     (1780186)	Comments: Entered a saved search that included both a SPAM and
the Trash folder on IMAP. The saved search took forever  so I closed Thunderbird
-> crash.  
     (1757152)	Comments: i had just updated one of the search folders with an
additional folder to search in  the Sent folder and had closed the wizard and
tried to run the seach several times to see if it would pick up a mail i had
just sent.  It didn't  so  thinking maybe if i
     (1757152)	Comments:  closed the prog. & restarted it...  So i closed the
prog. and it hung.
     (1756152)	Comments: importing from outlook
     (1745715)	Comments: Close Thunderbird window  by pressing 'close' icon in
the top-left corner.
     (1741592)	Comments: Thunderbird crashed while closing it.     Actions I did
before:  1. Uninstalling Thunderbird 0.73.  2. Installing Thunderbird 0.9 (using
existing accounts (5) with around 800MB in folder size together).  3. Adding two
"saved search" each searching in 10
     (1741592)	Comments:  user-made folders (containing mails from 10 to 1000 in
count). Each search results in around 80 mails.    After that  some "normal"
folders (with less than 50 mails) did not show its content or just randomly.
Larger folders where showing its content
     (1741592)	Comments:  correctly. (So it seems not to be a problem with
initialising folder content)    After restarting Thunderbird (which crashed
while closing) all folder behaved normally.    Furthermore  while clicking on a
"saved search" only one of them updates the
     (1741592)	Comments:  status message saying the amount of found mails.    
Contact me if further information is required.    Best regards  
     (1741060)	Comments: I was closing Thunderbird and Firefox at the same
time..  I had just done major changes in my setup in Thunderbird  added a coupl
eof search folders and added a RSS feed...
     (1735249)	Comments: closing thunderbird
     (1734148)	Comments: quitting the application the first time after playing
around with saved searches
     (1733930)	Comments: Crashed when I closed the application.  
     (1732393)	Comments: crashed on exit
     (1725941)	Comments: 1) Started Thunderbird 0.9 for the first time since
installing over 0.8  2) Connected to previously set up IMAP account  3) Created
a "saved search folder"  4) It looked fine  5) Went to sent-mail folder
(non-local)  6) ...and it "hung" for a while  so I
     (1725941)	Comments:  closed it after ~10 minutes
     (1723353)	Comments: installed the minimizetotray extension  and closed
program and crashed.
     (1721294)	Comments: I was just closing thunderbird.    I had updated from
firebird 0.8 to firebird 0.9    In this firebird 0.9 session I downloaded some
messages from a POP3 server and created a "Search folder"
     (1716583)	Comments: I closed the browser (first time after new install) 
installed over thunderbird 0.8 
 

This might be a dup of bug 267575.  If it is, this is most likely a cross
platform crash.
(Reporter)

Comment 1

14 years ago
Nominating for aviary1.0
Flags: blocking-aviary1.0?
(Reporter)

Updated

14 years ago
Summary: FF09 crash on closing Thunderbird [@ ntdll.dll - nsMsgDatabase::`scalar deleting destructor'] → TB09 crash on closing Thunderbird [@ ntdll.dll - nsMsgDatabase::`scalar deleting destructor']

Comment 2

14 years ago
probably a dup of bug 267575 - I'll check that fix into the branch (tomorrow,
probably) and see if it makes the reports go away.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 267575 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Flags: blocking-aviary1.0?
Crash Signature: [@ ntdll.dll - nsMsgDatabase::`scalar deleting destructor']
You need to log in before you can comment on or make changes to this bug.