TB10x crash syncing offline folder? [@ nsMsgDatabase::GetTableCreateIfMissing]

RESOLVED DUPLICATE of bug 292041

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 292041
13 years ago
13 years ago

People

(Reporter: jay, Assigned: Bienvenu)

Tracking

({crash, topcrash})

unspecified
x86
Windows XP
crash, topcrash
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
This is a topcrasher for Thunderbird 0.9.  Most user comments only mention
checking mail, but one comment mentioned synching offline folder...so I wonder
if that might the real cause.

Here's the latest from the latest TB09 Talkback data:
Count   Offset    Real Signature
[ 27   nsMsgDatabase::GetTableCreateIfMissing 6f451a68 -
nsMsgDatabase::GetTableCreateIfMissing ]
[ 2   nsMsgDatabase::GetTableCreateIfMissing 11167678 -
nsMsgDatabase::GetTableCreateIfMissing ]
 
     Crash date range: 03-NOV-04 to 09-NOV-04
     Min/Max Seconds since last crash: 3 - 88073
     Min/Max Runtime: 3 - 121006
 
     Count   Platform List 
     29   Windows XP [Windows NT 5.1 build 2600] 
 
     Count   Build Id List 
     29   2004110312
 
     No of Unique Users        12
 
 Stack trace(Frame) 

	 nsMsgDatabase::GetTableCreateIfMissing
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp
 line 1555] 
	 nsMailDatabase::GetAllOfflineOpsTable
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/db/msgdb/src/nsMailDatabase.cpp
 line 117] 
	 nsImapMailFolder::UpdateImapMailboxInfo
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/mailnews/imap/src/nsImapMailFolder.cpp
 line 2589] 
	 XPTC_InvokeByIndex
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp
 line 102] 
	 EventHandler
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/xpcom/proxy/src/nsProxyEvent.cpp
 line 545] 
	 0x778b0c24  
	 nsBaseCommandController::DoCommand
[e:/builds/tinderbox/thunderbird-branch/WINNT_5.0_Clobber/mozilla/embedding/components/commandhandler/src/nsBaseCommandController.cpp
 line 131]  
 
     (1731467)	Comments: starting v0.9 for the first time
     (1722639)	Comments: Opening a specific folder via IMAP with Thunderbird
consistantly crashes the program on each of the three different Windows XP
computers that I've tried.    The same folder works fine with both Squrrelmail 
and Eudora.  Presumably  it is because of a
     (1722639)	Comments:  malformed message contained therein  but Firefox is
short on clues as to what message that might be.
     (1722495)	Comments: Opening a specific folder via IMAP with Thunderbird
consistantly crashes the program on each of the three different Windows XP
computers that I've tried.    The same folder works fine with both Squrrelmail 
and Eudora.  Presumably  it is because of a
     (1722495)	Comments:  malformed message contained therein  but Firefox is
short on clues as to what message that might be.
 
====================================================================================================
     Count   Offset    Real Signature
[ 4   nsMsgDatabase::GetTableCreateIfMissing() f151e4d4 -
nsMsgDatabase::GetTableCreateIfMissing() ]
 
     Crash date range: 07-NOV-04 to 09-NOV-04
     Min/Max Seconds since last crash: 12786 - 410780
     Min/Max Runtime: 12786 - 410780
 
     Count   Platform List 
     4   [Darwin 7.6.0]      
 
     Count   Build Id List 
     4   2004110312
 
     No of Unique Users         4
 
 Stack trace(Frame) 

	 nsMsgDatabase::GetTableCreateIfMissing()
[/builds/thunderbird-release/0.9/mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp
 line 109] 
	 nsMailDatabase::GetAllOfflineOpsTable()
[/builds/thunderbird-release/0.9/mozilla/mailnews/db/msgdb/src/nsMailDatabase.cpp
 line 1148] 
	 nsMailDatabase::ListAllOfflineDeletes()
[/builds/thunderbird-release/0.9/mozilla/mailnews/db/msgdb/src/nsMailDatabase.cpp
 line 639] 
	 nsImapMailFolder::UpdateImapMailboxInfo()
[/builds/thunderbird-release/0.9/mozilla/mailnews/imap/src/nsImapMailFolder.cpp
 line 710] 
	 _XPTC_InvokeByIndex()	[nsWeakReference.cpp  line 256] 
	 EventHandler()
[/builds/thunderbird-release/0.9/mozilla/xpcom/proxy/src/nsProxyEvent.cpp  line
156] 
	 PL_HandleEvent()
[/builds/thunderbird-release/0.9/mozilla/xpcom/threads/plevent.c  line 674] 
	 PL_ProcessPendingEvents()
[/builds/thunderbird-release/0.9/mozilla/xpcom/threads/plevent.c  line 608] 
	 _md_EventReceiverProc()
[/builds/thunderbird-release/0.9/mozilla/xpcom/threads/plevent.c  line 1578] 
	 HIToolbox.145.0.0 + 0x1fc8 (0x927d1fc8)  
	 HIToolbox.145.0.0 + 0x223c (0x927d223c)  
	 HIToolbox.145.0.0 + 0x66bc (0x927d66bc)  
	 HIToolbox.145.0.0 + 0x12d54 (0x927e2d54)  
	 HIToolbox.145.0.0 + 0x2084 (0x927d2084)  
	 HIToolbox.145.0.0 + 0x223c (0x927d223c)  
	 HIToolbox.145.0.0 + 0x146e4 (0x927e46e4)  
	 HIToolbox.145.0.0 + 0x18600 (0x927e8600)  
	 HIToolbox.145.0.0 + 0x28740 (0x927f8740)  
	 HIToolbox.145.0.0 + 0x8db0 (0x927d8db0)  
	 HIToolbox.145.0.0 + 0x908c (0x927d908c)  
	 HIToolbox.145.0.0 + 0x1ca18 (0x927eca18)  
	 HIToolbox.145.0.0 + 0x2d730 (0x927fd730)  
	 nsMacMessagePump::GetEvent()
[/builds/thunderbird-release/0.9/mozilla/widget/src/mac/nsMacMessagePump.cpp 
line 407] 
	 nsMacMessagePump::DoMessagePump()
[/builds/thunderbird-release/0.9/mozilla/widget/src/mac/nsMacMessagePump.cpp 
line 312] 
	 nsAppShell::Run()
[/builds/thunderbird-release/0.9/mozilla/widget/src/mac/nsAppShell.cpp  line 114] 
	 xre_main()
[/builds/thunderbird-release/0.9/mozilla/toolkit/xre/nsAppRunner.cpp  line 710] 
	 _start()	[/SourceCache/Csu/Csu-45//SourceCache/Csu/Csu-45/crt.c  line 267] 
	 start()   
 
     (1838894)	Comments: checking "all mail" in thunderbird.  mixed imap and pop
     (1812585)	Comments: syncing offline folders

Comment 1

13 years ago
Scott and David, this is our top open topcrasher? Any change of getting this one
knocked out for 1.0?
Flags: blocking-aviary1.0?
(Assignee)

Comment 2

13 years ago
I'll look into it.
Assignee: mscott → bienvenu
(Assignee)

Comment 3

13 years ago
this one is very odd - I can't see why we'd crash at the location given by
talback. I wonder if the .msf file has been corrupted, but I don't see why that
would cause this problem.  Maybe uid validity has rolled? If only I could
reproduce this...
Having difficulty reproducing. Would need a patch, if one becomes available
should be renominated. Minusing for 1.0.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
(Reporter)

Comment 5

13 years ago
This continues to be a topcraser for Thunberbird 1.0.x:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=nsMsgDatabase%3A%3AGetTableCreateIfMissing&vendor=All&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid

Updating summary, although I still cannot reproduce this with the latest Aviary
or Trunk builds.
Summary: FF09 crash syncing offline folder? [@ nsMsgDatabase::GetTableCreateIfMissing] → TB10x crash syncing offline folder? [@ nsMsgDatabase::GetTableCreateIfMissing]
(Assignee)

Comment 6

13 years ago
potential fix checked in w/ bug 292041

*** This bug has been marked as a duplicate of 292041 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsMsgDatabase::GetTableCreateIfMissing]
You need to log in before you can comment on or make changes to this bug.