Open print preview or printing crashes Firefox [@ 0x03c5c4d5 @ nsGfxScrollFrame::Destroy]

VERIFIED DUPLICATE of bug 185357

Status

()

--
critical
VERIFIED DUPLICATE of bug 185357
14 years ago
13 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({crash})

1.7 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041112 Firefox/1.0

Openning the print preview or printing the website http://www.t-online.de
crashes my Firefox instance. I get different stack traces:

1. Opening the print preview

Talkback id: TB1922317G

Stack Signature	 0x03c42ae0 2f98ede3


2. Printing website

Talkback id: TB1922390Y

0x03c5c4d5
nsGfxScrollFrame::Destroy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 431]
nsFrameList::DestroyFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsFrameList::DestroyFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsFrameList::DestroyFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsTableFrame::Destroy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableFrame.cpp,
line 310]
nsTableOuterFrame::Destroy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/table/src/nsTableOuterFrame.cpp,
line 82]
nsPositionedInlineFrame::Destroy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsInlineFrame.cpp,
line 1103]
nsFrameList::DestroyFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsFrameList::DestroyFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/base/src/nsFrameList.cpp,
line 129]
nsPositionedInlineFrame::Destroy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsInlineFrame.cpp,
line 1103]
PresShell::Destroy 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 1868]

Can't reproduce it on other pages but every time on mentioned website.

Comment 1

14 years ago
Also crashes on XP, 1.0

Comment 2

14 years ago
Does crash with FF 1.0, doesn't crash with trunk build.
Version: unspecified → 1.0 Branch
(Reporter)

Comment 3

14 years ago
Like mentioned in the german newsgroup, this crash also appears for Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

OS => ALL, HW => ALL
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

14 years ago
Confirmed this on other sites too, for example, my online banking site
(www.bpo-banking.be).

Comment 5

14 years ago
Created attachment 181123 [details]
Stack trace

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050418
Firefox/1.0+

I was surprised to find that following the recipe in comment 0 , there was a
crash on the Mac. It may be a completely different crash. 

The actual bug may have been fixed ...

Comment 6

14 years ago
WFM FF1.0.3/WXP
(Reporter)

Comment 7

14 years ago
(In reply to comment #5)
> I was surprised to find that following the recipe in comment 0 , there was a
> crash on the Mac. It may be a completely different crash. 

It WFM too with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7)
Gecko/20050414 Firefox/1.0.3. It seems that the page was updated. I can't see
any frameset now which was in fact the problem of the crash. Cause we don't have
a attached testcase => WFM

Ben, your stack trace looks different to my one. It should be another issue.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 8

14 years ago
I filled bug 290930 with similar signature.
(Reporter)

Comment 9

14 years ago
*** Bug 290930 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

14 years ago
Reopen bug due to similar stack traces of bug 290930.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Open print preview or printing http://www.t-online.de crashes Firefox [@ 0x03c5c4d5 @ nsGfxScrollFrame::Destroy] → Open print preview or printing crashes Firefox [@ 0x03c5c4d5 @ nsGfxScrollFrame::Destroy]

Comment 11

14 years ago
-> Core / Printing
Assignee: firefox → printing
Status: REOPENED → NEW
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Version: 1.0 Branch → 1.7 Branch
TB report for a similar crash I got:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=6913062

This was on FF 1.0.4. It doesn't seem to happen for me on that site with DeerPark.
The www.peugeot-club.com URL (which was the reason this bug was re-opened)
crashes on the 2004-06-27 (and earlier) FF trunk builds, but not on 2004-06-28
and onwards.
This very strongly suggests that this is a duplicate of bug 185357, which was
fixed on the trunk on that date.

*** This bug has been marked as a duplicate of 185357 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ 0x03c5c4d5 @ nsGfxScrollFrame::Destroy]
You need to log in before you can comment on or make changes to this bug.