Plain text attachments are being sent inline

RESOLVED DUPLICATE of bug 65794

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 65794
13 years ago
13 years ago

People

(Reporter: Keith Jose, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If I compose an email in Thunderbird, attach a plain text file (extension does
not necessarily have to be .txt), the recipient will receive the email with the
attachment inline with no indication of an attachment in the message. 
This has been tested with the recipient using Eudora 6.1, Apple Mail 1.3.9,
MailSmith.
When I look in my sent folder in Thunderbird, I see the message formatted as I
have configured my Thunderbird, which is do not show attachments inline, and I
do see the message has my attachment. 
I have worked with the users of Eudora and Apple Mail to see if we can adjust
their settings to not view the attachments inline, but the problem is that they
get the message with no information of there being an attachment, so this I
presume is a problem with the header of the email when created in Thunderbird. 

It's very inconvenient if this is meant to be a feature because:
1) If I want to send inline text, then I will simply copy and paste it into my
message.
2) If I want to send a text file as an attachment, then there's probably a
pretty good reason for that, such as needing to keep that attachment as seperate
file.

Of course, I could zip the attachment, then send it, but... sometimes the files
are small, and it takes time. It's just not very efficient. 

Is there a way for me to tell Thunderbird to send attachments as attachments
always and not send my messages as a mixed content type? 

Reproducible: Always
Steps to Reproduce:
1.Compose new message
2.Attach plain text file
3.Send
4.Receive message in either Eudora or Apple Mail
5.Received message has no indication of an attachment.. everything's inline. 

Actual Results:  
Intended attachments appear inline. 

Expected Results:  
If I attach a file to a message, Thunderbird should keep the attachment an
attachment and not send it inline. I think Thunderbird currently accomplishes
this by setting the content type to a mixed content type. 
If I set all messages to be composed as plain text, then the content type should
b plain text-flowed with a flag in the header of there being an attachment.
(Reporter)

Comment 1

13 years ago
Please note that this is NOT about forwarding messages, which Thunderbird has a
configuration to allow for the forwarded message to either be inline or as an
attachment. 

Comment 2

13 years ago
See workaround at bug 65794 comment 11.

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.