Making the tabbed browsing feature more novice user friendly and promote the feature in a more aggressive manner

VERIFIED DUPLICATE of bug 268198

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 268198
14 years ago
14 years ago

People

(Reporter: Yuan Qi, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

After reading some user review of firefox and blogs of conversion stories, I
have noticed that it often takes the user a few weeks to discover the tabbed
browsing feature and experience its benefits. I believe tabbed browsing is not
being aggressively pushed as one of the revolutionary features of firefox. Here
are some of my suggestions to how this could be changed:

1. Adding a feature dialogue similar to the popup blocking feature dialogue.
This dialogue should explain to the user that tabs are used to load pages in the
background without interfering with their browsing and it should tell the user
how to distinguish a tab that is loading from a tab that has finished loading.

2. Replace the current set of tabbed browsing options with a simple option to
allow users to choose between traditional browsing and tabbed browsing.

3. The traditional browsing mode would mimic IE's behaviour, while the tabbed
browsing mode would open new tabs when the user presses enter in the urlbar and
searchbar or when they left click a bookmark. Also, under the tabbed browsing
mode, any web links provided under the help menu or any dialogues (such as the
"get more extensions" link in the extensions manager dialogue should open new
tabs instead of new windows.

4. Add a new tab button to the tab bar by default. This will preserve viewing
space, at the same time promoting tabbed browsing.

5. In addition to/instead of providing a close tab button at the end of the tab
bar, provide a close tab button at the end of each tab. This change would allow
users to close background tabs without interfering with their browsing. It is
also easier to reach. Although this function is provided in the "Tab X"
extension, I think it would be appropriate to include it as a core function.

Now some may argue that a lot of the functions described above is redundant,
since all of them can be done with middle clicking/through menus. The problem is
most novice users rarely use menus (at least not the menus in their browser) or
the middle buttons on their mice. Many of them are not even aware of the context
menu! Buttons and default behaviour are much more reliable ways of introducing
them to new functions.

I hope I have made some valid points with regard to the usability of tabbed
browsing in firefox. I hope the developers would give some consideration to
these points.

Reproducible: Always
Steps to Reproduce:
> 1. Adding a feature dialogue similar to the popup blocking feature dialogue.
> This dialogue should explain to the user that tabs are used to load pages in the
> background without interfering with their browsing and it should tell the user
> how to distinguish a tab that is loading from a tab that has finished loading.

Dialogs are bad.  I'm not a big fan of the popup blocked one, but that is
necessary to highlight where info on blocked popups will be once the infobar is
suppressed.

The rest is a dupe of the bug you already filed.

Close tab buttons on each button are largely a waste of space, and reduce the
amount of title length supported in a limited screen area.  They also create a
"danger" area that the user has to consciously avoid in order to switch tabs,
thereby impeding rapid movement.  (Think of it as a corollary to Fitts' Law.) 
Not going to happen.

*** This bug has been marked as a duplicate of 268198 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.