All thunderbird language pack links broken

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: Tuukka Tolvanen (sp3000), Assigned: Tuukka Tolvanen (sp3000))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Assignee)

Description

13 years ago
Going from http://www.mozilla.org/products/thunderbird/releases/ through
http://www.mozilla.org/projects/l10n/postinst-notes/tb03.html to langpack
download using the 'installable language pack' links:

Dutch langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-nlNL-langpack.xpi
Should be ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9.nl-NL.langpack.xpi

Finnish langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-fiFI-langpack.xpi
Should be ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9.fi-FI.langpack.xpi

German langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-deDE-langpack.xpi
Should be ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9.de-DE.langpack.xpi

Korean langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-koKR-langpack.xpi
No ko KR langpack xpi present on ftp in that directory

Polish langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-plPL-langpack.xpi
Should be ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9.pl-PL.langpack.xpi

Russian langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-ruRU-langpack.xpi
Should be ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird.0.9.ru-RU.langpack.xpi

Turkish langpack ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9-trTR-langpack.xpi
Should be ->
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/0.9/contrib-localized/thunderbird-0.9.tr-TR.langpack.xpi

*** This bug has been marked as a duplicate of 269631 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

13 years ago
reopening (see bug 269631 comment 4)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

13 years ago
Created attachment 165843 [details] [diff] [review]
doctor patch, add missing dashes to lpcode parts of cookies

Doctor - http://www.mozilla.org/products/thunderbird/releases/index.html

As far as I can tell, the change in
http://cvs-www.mozilla.org/webtools/bonsai/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla-org/html/projects/l10n/postinst-notes&command=DIFF_FRAMESET&file=tb03.html&rev2=1.2&rev1=1.1
is logically although it broke this for all langpacks (except Finnish, which
would have been broken already due to underscore vs dash in langcode, the third
item in the cookie).

lpcode, the third part of the cookie, is only used in tb03.html to construct
the langpack filename, so this patch adds the missing dashes to those.

The link to the nonexistent korean langpack is removed.
(Assignee)

Updated

13 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

13 years ago
Assignee: mozilla.webmaster → t.bugz
Status: ASSIGNED → NEW
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Why did these links always work in the past?  Was the file naming convention
changed?
(Assignee)

Comment 5

13 years ago
re comment 4, see the cvs-www.mozilla.org link in comment 3

ciopz@bigfoot.com, looks like tb03.html is yours, can you look this over and
check in if it makes sense?
(Assignee)

Comment 6

13 years ago
oh, the change I'm referencing in comment 3 is from 2003... I guess the langpack
filenames must have changed?
It looks like the filenames changed between 0.7.3 and 0.8.
Fixed for both 0.9 and 0.8.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

13 years ago
*groan* I missed another detail that's changed in the langpack filenames -- the
character on either side of lpcode is changed from '-' to '.'.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

13 years ago
Created attachment 165848 [details] [diff] [review]
part 2: s/-/./ on either side of lpcode
Created attachment 165854 [details] [diff] [review]
part 2, version 2

something like this might be better, but I'm trying to figure out how to test
it first
fixed
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

13 years ago
verified that 0.[987] 'installable language pack' links point to existing XPIs,
except
  - 0.7 Hebrew installable language pack and right to left theme (calls undefined
    function, does not set the cookie but goes to the same instructions page as
    the others)
  - 0.9 Russian installable language pack (the filename,
    thunderbird.0.9.ru-RU.langpack.xpi, starts with 'thunderbird.' rather than
    'thunderbird-' like the others.
This affects the links on
http://www.mozilla.org/projects/l10n/mlp_otherproj.html#thund_0.9 also! will fix
it today
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.