Instead of providing the Calendar extension, use CORBA instead

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: mozillabugs.3.maxchee, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I think providing Mozilla as an extension is a waste of resources and energy for
both the developers (to maintain the code) and the users (to install and
upgreade the extensions). I think it is more appropriate to use CORBA to embed
the calendar component into other applications. For example, when thunder
encounters an email with a .ics attachment, it will open up sunbird and use
CORBA to communicate with it and display the calendar inside the preview panel.

Reproducible: Always
Steps to Reproduce:
mozilla doesn't use corba. it does use xpcom.
And the extension and sunbird share 99% of the code, so not much pain there.
So what would be the benefit of stopping to provide an extension? we will only
loose users that actually want to use the extension?
(Reporter)

Comment 2

14 years ago
It's nice to know that sunbird and extension shares a lot of code. However, a
CORBA bridge would still be nice, since it allows external apps, such as
nautilus and openoffice to display/embed Sunbird calendars.

Comment 3

13 years ago
With the way this summary is phrased, it sounds like WONTFIX to me.  There may
be some merit it trying to incorporate corba compatibiltiy, but the calendar
extension certainly isn't going anywhere.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.