Closed Bug 269799 Opened 18 years ago Closed 17 years ago

"Clear All" privacy button / Clear Private Data tool don't cause cookies to be removed (according to visual feedback)

Categories

(Firefox :: Preferences, defect, P2)

1.5.0.x Branch
defect

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: olijbarton, Assigned: asaf)

References

Details

(Keywords: fixed1.8)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Click on the "Clear All" button in the Privacy Options, then clicking the "View
Cookies" button and the cookies are still listed until the options GUI is
exitted and re-entered again.  The visual feedback implies the cookies are still
present.

Reproducible: Always
Steps to Reproduce:
1.  View cookies to ascertain some are present
2.  Click "Clear All" button on the privacy options
3.  Click "View Cookies" and the cookies are still present
Actual Results:  
Cookies are still listed under "View Cookies" until the options GUI is exitted
and re-entered

Expected Results:  
Shown the cookie list as empty after clicking "Clear All"
Seeing this also, easy to confirm, 
go to any online store
add something to your cart
clear all
go back to cart
voila, cookies are still there.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
*** Bug 311664 has been marked as a duplicate of this bug. ***
Assignee: firefox → bugs.mano
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Priority: -- → P2
Hardware: PC → All
Summary: "Clear All" privacy button doesn't cause cookies to be removed (according to visual feedback) → "Clear All" privacy button / Clear Private Data tool don't cause cookies to be removed (according to visual feedback)
Target Milestone: --- → Firefox1.5
Version: unspecified → 1.5 Branch
Status: NEW → ASSIGNED
Attached patch patchSplinter Review
Attachment #198936 - Flags: review?(mconnor)
Comment on attachment 198936 [details] [diff] [review]
patch

It'd be nice to know why we didn't use removeAll here in the first place, its
much much faster..
Attachment #198936 - Flags: review?(mconnor) → review+
(In reply to comment #5)
> (From update of attachment 198936 [details] [diff] [review] [edit])
> It'd be nice to know why we didn't use removeAll here in the first place, its
> much much faster..
> 

Maybe Ben knows.
Trunk:
mozilla/browser/base/content/sanitize.js 1.11
mozilla/browser/components/preferences/cookies.js 1.11
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Attachment #198936 - Flags: approval1.8rc1?
Attachment #198936 - Flags: approval1.8rc1? → approval1.8rc1+
1.8 branch:
Checking in browser/base/content/sanitize.js;
/cvsroot/mozilla/browser/base/content/sanitize.js,v  <--  sanitize.js
new revision: 1.5.2.6; previous revision: 1.5.2.5
done
Checking in browser/components/preferences/cookies.js;
/cvsroot/mozilla/browser/components/preferences/cookies.js,v  <--  cookies.js
new revision: 1.9.2.1; previous revision: 1.9
done
Keywords: fixed1.8
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.