Trunk crash [@ PL_strcmp - nsPluginHostImpl::RemoveCachedPluginsInfo ] trying to load this site

RESOLVED DUPLICATE of bug 269472

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 269472
13 years ago
6 years ago

People

(Reporter: Bill Mason, Unassigned)

Tracking

({crash, regression, topcrash})

Trunk
x86
Windows XP
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB1946169Y, crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041109 Firefox/0.9.1+
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-11-12-06-trunk/

This page does a JavaScript check for Flash, and then forward to another page as
appropriate.  Starting with the 2004111206 build, the browser is crashing
somewhere in the check.  Crashes do not occurs with the 2004111107 build.

Reproducible: Always
Steps to Reproduce:
1. Visit the page.
Actual Results:  
Crash.

Expected Results:  
Forwarded to http://www.startrek.com/startrek/view/index.html.

Talkback TB1946169Y
(Reporter)

Updated

13 years ago
Keywords: crash, regression
Whiteboard: TB1946169Y

Updated

13 years ago
Keywords: talkbackid
PL_strcmp 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/nsprpub/lib/libc/src/strcmp.c,
line 47]
nsPluginHostImpl::RemoveCachedPluginsInfo 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 5523]
ntdll.dll + 0x10551 (0x7c910551)
nsPluginHostImpl::ScanPluginsDirectoryList 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 4976]
nsPluginHostImpl::FindPlugins 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 5085]
nsPluginHostImpl::ReloadPlugins 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 2659]
PluginArrayImpl::Refresh 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dom/src/base/nsPluginArray.cpp,
line 203]
PluginArrayImpl::Refresh 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dom/src/base/nsPluginArray.cpp,
line 259]
XPTC_InvokeByIndex 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2036]
XPC_WN_CallMethod 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1288]
js_Invoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1288]
js_Interpret 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 3509]
js_Invoke 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1307]
js_Interpret 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 3509]
js_Execute 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1565]
JS_EvaluateUCScriptForPrincipals 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c, line
3700]
nsJSContext::EvaluateString 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 997]
nsScriptLoader::EvaluateScript 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 673]
nsScriptLoader::ProcessRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 587]
nsScriptLoader::ProcessScriptElement 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsScriptLoader.cpp,
line 536]
nsHTMLScriptElement::MaybeProcessScript 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 657]
nsHTMLScriptElement::SetDocument 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 449]
nsGenericElement::AppendChildTo 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 2602]
HTMLContentSink::ProcessSCRIPTTag 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 4255]
HTMLContentSink::AddLeaf 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3123]
HTMLContentSink::AddHeadContent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3076]
CNavDTD::AddHeadLeaf 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 3832]
CNavDTD::HandleStartToken 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 1822]
CNavDTD::HandleToken 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 1006]
CNavDTD::BuildModel 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 481]
nsParser::BuildModel 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/nsParser.cpp,
line 2032]
nsParser::ResumeParse 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/nsParser.cpp,
line 1896]
nsParser::OnDataAvailable 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/parser/htmlparser/src/nsParser.cpp,
line 2577]
0x026ffae8
necko.dll + 0x5df84 (0x608fdf84)
nsHttpChannel::AddRef 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp,
line 2792]
0x8b5610ec
Keywords: talkbackid
Summary: Crash trying to load this site → Crash [@ nsPluginHostImpl::RemoveCachedPluginsInfo PL_strcmp ] trying to load this site

Comment 2

13 years ago
Maybe I am totaly wrong here, but in the german newsgroup
de.c.s.m.nightly-builds starting with MID <cn836s.2qo.1@privat.lahls.de> we are
just talking about some crashers starting something later than 2004111109 (last
known good) and 2004111119 (first known crasher) at the URI:
http://8simplerules.tvheaven.com/

This crashes Mozilla-Seamonkey reproduceable in some way caused by the Plugins. 
Also about:plugins crashes Mozilla, tested with Build ID 2004111119 and newer is
crashing. 

I have installed Sun Java RE 1.5.0-Beta 2 *and* copied the Plugin.dlls into the
mozilla\plugins-Folder. 

Deleting the Java-dlls (NPOJI610.dll etc.) solves the crash on the Site above
and about:plugins page for me. Also the JRE still runs from the
Java-Install-Folder. You URL does not crash Mozilla to here with the cleaned
Plugins-Folder. 

RĂ¼diger and me are using Mozilla-Seamonkey Trunk-Builds, but because you are
using an FF-Trunk-Build to it is maybe the same crash. 

Reporter, if you have the Java-Plugin installed and copied the plugin-dlls, try
to delete them from your Plugin-Folder.

Comment 3

13 years ago
Have tried to reproduce crash: 

When I have copied (as formerly usual) the: NPOJI610.dll, NPJPI150.dll,
NPJava32.dll, NPJava14.dll, NPJava13.dll, NPJava12.dll and NPJava11.dll into the
..\mozilla.org\mozilla\plugins Folder, Mozilla Mozilla/5.0 (Windows; U; Windows
NT 5.0; en-US; rv:1.8a5) Gecko/20041114 Mnenhy/0.6.0.104 {Build ID: 2004111410}
crashes reproduceable from your given URI http://www.startrek.com/

Deleting the Files solves the crash, the above URI brings me to the Forward-Site.
(Reporter)

Comment 4

13 years ago
>RĂ¼diger and me are using Mozilla-Seamonkey Trunk-Builds, but because you are
using an FF-Trunk-Build to it is maybe the same crash. 

I'm reporting this on a Seamonkey build, not a FF build (though I can reproduce
it on FF trunk builds).

>Reporter, if you have the Java-Plugin installed and copied the plugin-dlls, try
to delete them from your Plugin-Folder.

I have not copied the plugins, and they are not present in the plugins folder of
my installation.
(Reporter)

Comment 5

13 years ago
(In reply to comment #2)
> just talking about some crashers starting something later than 2004111109 (last
> known good) and 2004111119 (first known crasher) at the URI:
> http://8simplerules.tvheaven.com/

This URL does not crash for me.  It appears you're talking about Java issues on
that URL, whereas I'm seeing Flash issues.
(Reporter)

Comment 6

13 years ago
I sort of suspect this is caused by the checkin for bug 265936.  This bug could
be related to bug 269472.
(Reporter)

Comment 7

13 years ago
Bug 265936 just had its fix back out.  If it is the cause of this, tomorrow's
builds should not show this bug.
Depends on: 265936

Updated

13 years ago
Assignee: general → nobody
Component: Browser-General → Plug-ins
QA Contact: general → core.plugins

Comment 8

13 years ago
(In reply to comment #4)

> I'm reporting this on a Seamonkey build, not a FF build (though I can reproduce
> it on FF trunk builds).

Urgh, sorry, I missed that. 

But backing out the patch for Bug 265936 has fixed the crash from
http://www.startrek.com/ for me also when i have copied the Java-plugin dlls
into the plugins-folder with Trunk-Build 2004111419. Thanks. 

(In reply to comment #5)

> > known good) and 2004111119 (first known crasher) at the URI:
> > http://8simplerules.tvheaven.com/
> 
> This URL does not crash for me.  It appears you're talking about Java issues on
> that URL, whereas I'm seeing Flash issues.

Well, i thought this was also caused by scanning the plugins, because i can't
see an java-applet on this Site. The new Build wont crash on this Site anymore. 
(Reporter)

Comment 9

13 years ago
Confirming that the backout of the patch in bug 265936 did stop this crash.
20041115 PC/Win2000.

Comment 10

13 years ago
This is a topcrasher on the MozillaTrunk, but only because one guy has been
crashing at URL: http://slashdot.org/article.pl?sid=04/11/14/1813223 .  He has
sent in over 30 Talkback reports for the same crash, but at least he's
consistent. :-)

Here's one of his recent incidents:
Incident ID: 1955540
Stack Signature	PL_strcmp bfa2dfcd
Product ID	MozillaTrunk
Build ID	2004111204
Trigger Time	2004-11-14 20:06:16.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	plc4.dll + (000012a2)
URL visited	http://slashdot.org/article.pl?sid=04/11/14/1813223
User Comments	
Since Last Crash	48 sec
Total Uptime	171368 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/nsprpub/lib/libc/src/strcmp.c,
line 47
Stack Trace 	
PL_strcmp 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/nsprpub/lib/libc/src/strcmp.c,
line 47]
nsPluginHostImpl::RemoveCachedPluginsInfo 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 5523]
ntdll.dll + 0x10551 (0x7c910551)
nsPluginHostImpl::FindPlugins 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 5133]
nsPluginHostImpl::ReloadPlugins 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 2659]
nsPluginHostImpl::SetUpPluginInstance 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 3692]
nsPluginHostImpl::InstantiateEmbededPlugin 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 3368]
nsObjectFrame::InstantiatePlugin 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsObjectFrame.cpp,
line 1303]
nsObjectFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsObjectFrame.cpp,
line 1149]
nsLineLayout::ReflowFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 1002]
nsInlineFrame::ReflowInlineFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsInlineFrame.cpp,
line 710]
nsInlineFrame::ReflowFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsInlineFrame.cpp,
line 528]
nsInlineFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsInlineFrame.cpp,
line 442]
nsLineLayout::ReflowFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 1002]
nsBlockFrame::ReflowInlineFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3751]
nsBlockFrame::DoReflowInlineFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3576]
nsBlockFrame::ReflowInlineFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3465]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2583]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3215]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2465]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3215]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2465]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3215]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2465]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowFloat 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5271]
nsBlockReflowState::FlowAndPlaceFloat 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 868]
nsBlockReflowState::AddFloat 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 672]
nsLineLayout::ReflowFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 1024]
nsBlockFrame::ReflowInlineFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3751]
nsBlockFrame::DoReflowInlineFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3576]
nsBlockFrame::ReflowInlineFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3465]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2583]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowFloat 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5271]
nsBlockReflowState::FlowAndPlaceFloat 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 868]
nsBlockReflowState::AddFloat 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowState.cpp,
line 672]
nsLineLayout::ReflowFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 1024]
nsBlockFrame::ReflowInlineFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3751]
nsBlockFrame::DoReflowInlineFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3576]
nsBlockFrame::ReflowInlineFrames 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3465]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2583]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3215]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2465]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2121]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 837]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 544]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3215]

The stack looks the same, so the slashdot case might have the same problem as
the startrek page.
Keywords: topcrash
Summary: Crash [@ nsPluginHostImpl::RemoveCachedPluginsInfo PL_strcmp ] trying to load this site → Trunk crash [@ PL_strcmp - nsPluginHostImpl::RemoveCachedPluginsInfo ] trying to load this site
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> This is a topcrasher on the MozillaTrunk, but only because one guy has been
> crashing at URL: http://slashdot.org/article.pl?sid=04/11/14/1813223 .  He has
> sent in over 30 Talkback reports for the same crash, but at least he's
> consistent. :-)
> 
> The stack looks the same, so the slashdot case might have the same problem as
> the startrek page.

FWIW, my builds that crash at startrek.com do not crash at this slashdot page.

Comment 12

13 years ago
No crashes in Talkback data since 11/14.  Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 13

13 years ago

*** This bug has been marked as a duplicate of 269472 ***
Resolution: WORKSFORME → DUPLICATE
(Assignee)

Updated

6 years ago
Crash Signature: [@ PL_strcmp - nsPluginHostImpl::RemoveCachedPluginsInfo ]
You need to log in before you can comment on or make changes to this bug.