Cannot import Netscape address books.

RESOLVED DUPLICATE of bug 35509

Status

RESOLVED DUPLICATE of bug 35509
14 years ago
14 years ago

People

(Reporter: rubenbenabraham, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a4) Gecko/20040927

I have used Netscape before switching to Mozilla. Always have been using the
latest version of Netscape. Mozilla facilitates import of address books from
Eudora, Outlook, Outlook Express, Text Files - but there is no provision for
importing Netscape address books, why is that? It really frustrates me. Hope you
find a solution to that one soon.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
do you mean netscape 4.x? We can't import those because they're in a proprietary
format we (Mozilla) can't read. However, Netscape 6 and 7.x can import Netscape
4.x address books,  and Mozilla can read Netscape 6 and 7.x format address
books. Or, you can use Netscape 4.x to export to ldif, and then import from ldif
into Mozilla.

Comment 2

14 years ago
> Always have been using the latest version of Netscape. 

Please always explicitly indicate version and build number of product you are
referring to when filing up a bugfile. Also, always provide steps to reproduce:
sometimes, the problem is in there.

> there is no provision for importing Netscape address books, why is that?

Bug 35509. This issue was mentioned in the release notes of Mozilla 1.8a4 and
Mozilla 1.7.x under "known issues" in mail and newsgroup.

David gave you a perfectly working workaround for this problem. 

I'm resolving this bug as duplicate of bug 35509. Reopen this bug and provide
more details, specifics if there is a problem with importing NS 6.x or NS 7.x
address books in the latest nightly trunk build of Mozilla.

http://www.mozilla.org/quality/bug-writing-guidelines.html

*** This bug has been marked as a duplicate of 35509 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
Didn't think it necessary explaining how to reproduce the bug since there is
only one way to import address books within the Mozilla environment for the
common user:
(1) pull-down menu "Window"
(2) "Address Book"
(3) pull-down menu "Tools"
(4) "Import..."
(5) radio button "Address Books"
(6) "Next" button
(7) only find Eudora, Outlook, Outlook Express, Text file
(8) don't see the word "Netscape-6" or "Netscape-7" in that list

Anyway, I found my own solution by taking the part of the Netscape-7 address
book which contains the address entries and combining it with the structure part
of the address book one can create with Mozilla, then give the new creation an
external name which makes Mozilla think that it is dealing with a user-created
address book, i.e. "abook-1.mab"

Comment 4

14 years ago
(In reply to comment #3)
> Didn't think it necessary explaining how to reproduce the bug since there is
> only one way to import address books within the Mozilla environment for the
> common user:

The bug writing guidelines should apply to any/all bugfiles as much as possible
to ease the process of reproducing, to avoid confusion, to facilitate general QA
work for people with various backgrounds, different levels of Mozilla
understanding, various habits/expertise of usage, limited time, etc.. If only
people would follow strictly bug reporting guidelines (including searching for
duplicates), it would reduce the number of unconfirmed bugs (right now, over
8,000 bugs) and ease the process of searching for duplicates. People who spend
their time processing bugreports and QA are volunteers. 
FYI, I have requested to reopen bug 258257; I might add later some changes to
the current text in the helpfile.

> (1) pull-down menu "Window"
> (2) "Address Book"
> (3) pull-down menu "Tools"
> (4) "Import..."
> (5) radio button "Address Books"
> (6) "Next" button
> (7) only find Eudora, Outlook, Outlook Express, Text file
> (8) don't see the word "Netscape-6" or "Netscape-7" in that list
> 

Text file is not a program and Mozilla does not store its address book file in
an ldif format: the file is a *.mab file. So, right here, unless the user use
the NS 6.x/NS 7.x profile, the user can not and will not find out how to import
the address book from NS 6.x or NS 7.x. Like you say, there is no provision for
importing address books from NS 6.x or NS 7.x.

> Anyway, I found my own solution by taking the part of the Netscape-7 address
> book which contains the address entries and combining it with the structure part
> of the address book one can create with Mozilla, then give the new creation an
> external name which makes Mozilla think that it is dealing with a user-created
> address book, i.e. "abook-1.mab"

This is a manual import and a rather complex one, I'd say.
I should have resolved as a duplicate of bug 138980 instead.
"having to export all addresses as text then re-import is silly."
https://bugzilla.mozilla.org/show_bug.cgi?id=121725#c9

The helpfile should cover better this NS 6.x/NS 7.x addressbook to Mozilla issue
for starters.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.