PAC: mozilla help needs to document proxy auto-configuration files

RESOLVED DUPLICATE of bug 213699

Status

RESOLVED DUPLICATE of bug 213699
14 years ago
4 years ago

People

(Reporter: bmo, Assigned: benc)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

there is currently no help topic that describes how to write and use a proxy
configuration file (aka PAC file).  i first thought bug 128270 was tracking
this, but apparently was mistaken. i then opened bug 244640, but that morphed
into tracking an end-user online document not a help file addition.  hopefully
this bug will stay on target.

Reproducible: Always
Steps to Reproduce:
Docs sort of like this? http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html

(Camino's proxy help was linking to that, but I think for our [Camino's] purposes http://www.mozilla.org/catalog/end-user/customizing/enduserPAC.html makes more sense--once I followed the trail to find the enduserPAC doc.)
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Docs sort of like this?
> http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html

nice find!  yes... that's the kind of documention mozilla (and firefox) need.
(Reporter)

Updated

13 years ago
Blocks: 324571

Comment 3

13 years ago
(In reply to comment #2)
>>http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html
>nice find!  yes... that's the kind of documention mozilla (and firefox) need.

It needs both; and the text "Have the network administrator look at the Technical Guide to PAC for more information." in the End User Guide should link to (an updated and imported version of) proxy-live.html.

proxy-live.html probably needs checking against the current state of this code and any relevant Bugzilla and developer links added.

(Thanks for the find Smokey!)

Comment 4

13 years ago
(In reply to comment #1)
> Docs sort of like this?
> http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html
> (Camino's proxy help was linking to that, but I think for our [Camino's]
> purposes http://www.mozilla.org/catalog/end-user/customizing/enduserPAC.html
> makes more sense--once I followed the trail to find the enduserPAC doc.)

We actually have a link to http://www.mozilla.org/catalog/end-user/customizing/enduserPAC.html already (in SeaMonkey Help). But that doesn't tells you how to actually write the file, though.

That said, I don't know if any built-in Help doc need this. For the SeaMonkey/Firefox user the link to the enduserPAC doc should suffice. If someone added a link to an updated version of proxy-live.html in enduserPAC I think we would be fine here.

(Assignee)

Comment 5

13 years ago
I am working on a detailed document for network administrators... In bug 142498. I got sidetracked for a while, but I'll try to get a draft off my local tree and into bugzilla...

Regarding the actual help file, I can see why a help file entry is needed to sit beside online documentation. My personal focus on clear, detailed technical documentation, but I would be glad to help someone else write the PAC text for the help files.
Depends on: 142498
(Assignee)

Comment 6

10 years ago
-> I'll do it, for Seamonkey.
Assignee: help.viewer → benc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213699
You need to log in before you can comment on or make changes to this bug.