Closed Bug 269927 Opened 15 years ago Closed 14 years ago

Tooltip appears after closing tab (even after switching windows) (and doesn't go away easily)

Categories

(Core :: XUL, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: martijn.martijn)

References

Details

(Keywords: regression)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041112
Firefox/0.9.1+

Steps to reproduce:
1. Middle-click a link
2. Middle-mouse-down on the new tab.
3. Move the cursor at least one pixel.
4. Middle-mouse-up.
5. Don't move the cursor at all.  Wait one second.

Result: black phantom tooltip appears.

I hit this bug four times in two days before I figured out how to reproduce it.
Component: Tabbed Browser → General
I've been seeing the same bug too recently (or at least something that sounds
very similar), but for whatever reason I can't seem to reproduce using your
instructions.
Assignee: bugs → firefox
QA Contact: firefox.tabbed-browser → firefox.general
Version: 1.0 Branch → Trunk
Flags: blocking-aviary1.1?
I'm also seeing this, but it appears to be random... 
It could also be related to some extention...
Nope not related to an extention. Still seeing this with a clean profile:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050212 Firefox/1.0+
(P4 1,6Ghz, 512RAM)
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b2) Gecko/20050220 Firefox/1.0+

Using this build, I cannot reproduce. I get a tooltip, but it is not all black.
It is the tooltip that would come up from just hovering over the tab.

I tested this by setting middlemouse.contentLoadURL to false.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050220
Firefox/1.0+

The tooltip is no longer all-black, but it still appears.  The most annoying
aspects of this bug is still present: the tooltip doesn't go away if you move
your mouse after step 5, and it appears even if you Alt+Tab before step 5.
Summary: [trunk] All-black tooltip appears after closing tab → Tooltip appears after closing tab, even after switching windows
Summary: Tooltip appears after closing tab, even after switching windows → Tooltip appears after closing tab (even after switching windows) (and doesn't go away easily)
I still get the tooltip for the "old" tab, but it now goes away after a short
timeout.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050302
Firefox/1.0+
Flags: blocking-aviary1.1? → blocking-aviary1.1+
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050311
Firefox/1.0+ 12:39 PST

I can't reproduce this anymore with the build that includes the patch for bug 285000
(In reply to comment #8)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050311
> Firefox/1.0+ 12:39 PST
> 
> I can't reproduce this anymore with the build that includes the patch for bug
285000

me 2 ....finally :)
->WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
I still see this bug, at least when there are 3 tabs open before I close one.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050312
Firefox/1.0+
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This bug is also present in Mozilla 1.8b (Seamonkey).
not always black here but I do see this phantom tooltip often
Just tried it, still showing up with this version. Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050510 Firefox/1.0+  (bangbang023)
unless i am missing something, i do not see the problem any longer...

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050521
Firefox/1.0+

i suggest this go to RESOLVED FIXED status...unless anyone else can  verify and
how so?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050521
Firefox/1.0+

I still see this bug using the steps in comment 0 and comment 11.
Attached patch patchSplinter Review
This makes the bug go away for me.
But maybe a better fix would be somewhere here:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTooltipListener.cpp&rev=1.42&root=/cvsroot#389

I think that line of code still returns true when a tab is removed with
removeChild, not?
Assignee: firefox → mconnor
Status: REOPENED → NEW
*** Bug 298238 has been marked as a duplicate of this bug. ***
Flags: blocking1.8b4?
Flags: blocking1.8b3?
Flags: blocking1.8b3-
Attached patch patch2Splinter Review
This patch fixes this specific issue by adding a mouseup listener.
It wouldn't work in general, though, when content suddenly gets removed from
the dom.
However, this still might be something that is worthwhile.
Could someone set some review flags for the patch?
Attachment #187139 - Flags: review?(bryner)
Attachment #187139 - Flags: review?(bryner) → review+
Comment on attachment 187139 [details] [diff] [review]
patch2

Like I said, this patch fixes this bug, but not the more general case when
content suddenly gets removed from
the dom
Attachment #187139 - Flags: superreview?(bzbarsky)
Comment on attachment 187139 [details] [diff] [review]
patch2

sr=bzbarsky (though this should move to the core product, really).  Could you
please file a followup bug on the DOM issue and cc me?	Especially if you have
steps to reproduce it (with testcase or browser UI or whatever).  That
shouldn't be so hard to fix by observing document notifications, really.
Attachment #187139 - Flags: superreview?(bzbarsky) → superreview+
Ok, I filed bug 300808 for that.
Comment on attachment 187139 [details] [diff] [review]
patch2

This fixes an irritating little bug and is very safe.
Attachment #187139 - Flags: approval1.8b4?
Assignee: mconnor → martijn.martijn
Attachment #187139 - Flags: approval1.8b4? → approval1.8b4+
If someone could check in, that would be great.
Whiteboard: [checkin needed][a+]
the patch was checked in by timeless, marking FIXED.
Status: NEW → RESOLVED
Closed: 15 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed][a+]
Component: General → XP Toolkit/Widgets: XUL
Flags: review+
Product: Firefox → Core
(the patch had r=bryner before the product change)
Flags: blocking1.8b4?
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: general → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.