If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Closing Tab: Wrong Tab becomes top

VERIFIED DUPLICATE of bug 105722

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 105722
13 years ago
9 years ago

People

(Reporter: Klaus Kusche, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041113

When I close a tab, as far as I can tell, always the tab immediately to the left
of the closed tab is brought to top (becomes the visible / selected tab).

Wrong. The "parent" tab of the closed tab (i.e. the tab which was top when the
closed tab was opened) should become the new top (visible) tab (and if that tab
doesn't exist any more, its parent, or grandparent etc.), because that's usually
the tab I want to go back to.

Konqueror does that right...


Reproducible: Always
Steps to Reproduce:
1. Two tabs open, left one on top.
2. Open a new tab.
3. Close the new tab.

Actual Results:  
The right of the two original tabs is shown.

Expected Results:  
The left of the two original tabs should be shown, because it was the tab I
looked at before opening the new tab.

*** This bug has been marked as a duplicate of 105722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
1.) The bug you dup'ed this one to is marked "resolved-wontfix", as are almost a
dozen similar bugs.

2.) Looking at some of these bugs, they still seem to get *several dup's per
week*! So obviously many people feel that this is definitely something which
needs to be fixed.

3.) From a user's perspective, if I open some sub-page (or popup) of some tab,
and close it again, I expect to see the original tab. Period. Anything else is
definitely a bug, and disrupting my work.

4.) The second-most-widespread open-source browser, Konqueror, does the
(intuitively) right thing most of the time, and people seem to be more happy
with it. This clearly and undisputably demonstrates that this is something which
can be improved and should be improved.

I don't care about the theory behind it (whether parent or Z-ordering), and I
don't care what is done in rare corner cases (e.g. when the parent no longer
exists or when I work with two groups of pages alternatingly), I just want my
browser to do the intuitively right thing in as many of the cases as possible.

The current behaviour is intuitively wrong w.r.t. most user's expectations in
most cases, and is the worst of all possible choices, so any change (no matter
whether based on parents or Z-ordering) is a vast improvement.

I observed myself for several hours now. At least for my surfing habits (in
Konqueror, not Mozilla, strictly using a single window with tabs only),
Mozilla's current method would top the wrong tab after at least 80 % of all tab
closes (because it also opens the tabs in the wrong place - opening them right
of the parent would already help a lot). Of these > 80 % fails, both proposed
methods would fix about 90 %, they would differ only in less than 10 % (because
in practice the simple and obvious cases occur by far more often than the
complicated and hard-to-decide ones). 

So, pleeeease, reopen one of these bugs, and do something about it.
Don't discuss about 10-20 % complicated corner cases, don't worry what the
perfect solution is (there is none as long as mozilla can't read our brains),
but fix the 80 % simple and obviously wrong cases first, otherwise mozilla is
falling behind the competition.

There won't be an immediate perfect cure, but we urgently need a first relief
from the major pains this misbehaviour causes in daily work.

By the way: During my several-hour usability self-study, I noticed that at least
w.r.t. my expectations, the parent algorithm would have done the right thing
slightly more often than Z ordering:
* I work with a group of related tab's, let's call them "A".
* My work get's interrupted, e.g. by some newly arrived mail with links in it or
whatever. This leads to another group of pages, let's call them "B".
* After looking at some "B" tabs, I decide to investigate "B" more closely
later. Hence, I leave the "B" tabs open, but continue my work in the "A" group
of tabs.
* Now I close an "A" tab which I looked at before "B" was started. The parent
algorithm takes me to the "A" tab from which the closed tab was opened. This
meets my expectation, because I'm concentrating on "A" matters now. The
Z-ordering algorithm would have taken me to the last "B" tab I've looked at,
which isn't quite what I'm looking for at that moment.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
>1.) The bug you dup'ed this one to is marked "resolved-wontfix", as are almost a
>dozen similar bugs.

that is correct. but that doesn't change the fact that this is a duplicate.
please argue in that bug, not here.

*** This bug has been marked as a duplicate of 105722 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.