FireFox unable to switch from anything else than the default theme on a user account

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: D. Grimaldo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I have downloaed and installed a theme (Noia Xtreme) for FireFox 1.0. On the
administrative account I am apparently able to switch to the new theme after
reloading.

I also installed the theme on my regular (restricted) account. In appeared there
after the upgrade of the theme too (like in the other account). However, if I
select the new theme and then reload the browser, the original (FIrefox) theme
is still showing as default.

Where is FireFox storing these preferences, in the registry or in Application
Data? I fear there is some permission problem causing this. Please advise so
that I can check the permissions (once I know where).

Reproducible: Always
Steps to Reproduce:
1. Install a new theme on a Restricted account's FireFox Browser (WInXP Pro)
2. Select the new theme as the default (Rather than the old FireFox theme)
3. Reload the browser
4. The old theme that WAS the default is STILL the default. New theme still
shows as non-default.

Actual Results:  
The old theme is still in effect

Expected Results:  
The newly selected theme should be used.

Comment 1

14 years ago
As far as I know, selected theme information is stored in profile (app
data/mozilla/firefox/), unless you install with -install-global-theme.
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

13 years ago
Nowadays it works but then again I have since (long time ago!) upgraded to v1.0.4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.