Bookmarks menu should remain visible after context-menu sorting

RESOLVED DUPLICATE of bug 195031

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 195031
13 years ago
11 years ago

People

(Reporter: Ney André de Mello Zunino, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The "sort by name" feature works fine from the context menu, rearranging the
items on the current level. However, the bookmarks menu is hidden as the user
activates the command. This makes it rather annoying and cumbersome to sort a
couple of folders, particularly when they are deep in the bookmarks hierarchy.
In addition, letting the user see the change would make it a lot more intuitive.

Reproducible: Always
Steps to Reproduce:
1. Open the bookmarks menu.
2. Navigate to some folder you wish to sort, preferably one deep in the hierarchy.
3. Bring up the context menu and activate "Sort by name".

Actual Results:  
The chosen folder did get sorted, but the bookmarks menu (all the levels)
disappeared.

Expected Results:  
The menus should have been kept visible so that the user could spot the sorting
changes instantly and also be able to sort some other folder nearby, without
having to reopen all the menu levels once again.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 195031 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.