Right-click to use context menu moves text cursor

RESOLVED DUPLICATE of bug 260583

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 260583
13 years ago
9 years ago

People

(Reporter: Craig, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040910

When in any other part of Mozilla, such as this box on this form, right-clicking
simply causes a context menu to pop up. When composing email, right-clicking
causes the text cursor to move to the line closest to where the mouse happens to
be. This is extremely unintuitive, especially as the most likely purpose is to
use "paste", thus making the pasted text go in an unintended place.

It's not only inconsistent with the rest of Mozilla, but inconsistent in that
"paste" done by keyboard shortcut performs a significantly different task than
"paste" done by right-click, since the former inserts the text in the desired
location, at the current text cursor location, while the latter does not.


Reproducible: Always
Steps to Reproduce:
1. Compose
2. Type some text
3. Right-click

Actual Results:  
If your mouse is pointing anywhere within in the current text area, the text
cursor will be moved.

Expected Results:  
The text cursor should stay put.

Comment 1

13 years ago
This behavior is typical of all the editors and word processors I have used.
(Reporter)

Comment 2

13 years ago
Simple counter-example: Notepad.

Another issue of inconsistency is that it doesn't happen if the mouse pointer is
below the area of current text. There is, however, no way to tell visually
whether this is the case!

If you right-click when the mouse pointer is within the current text area, the
text cursor is moved to the end of the current line. If you right-click when the
mouse pointer is below the current text area, the text cursor isn't moved. If a
right-click "should" move the text cursor, it shouldn't require that the mouse
pointer be within the bounds of the current text, just the text entry area. ie.
Right-clicking below the current text should move the text cursor to the end of
the last line. (as happens in Wordpad)

Comment 3

13 years ago
(In reply to comment #2)
> Simple counter-example: Notepad.

Only the worst editor ever written!

*** This bug has been marked as a duplicate of 260583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.