Ctrl-A doesn't select all text in text field: Moves to beginning of line instead

RESOLVED DUPLICATE of bug 257405

Status

--
minor
RESOLVED DUPLICATE of bug 257405
14 years ago
10 years ago

People

(Reporter: Klaus.Kusche, Assigned: blizzard)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041113

My Mozilla is built with GTK+ 2.4.9 (I don't know if this is GTK+-specific or not).

When focus is in a forms text field like the one I'm typing to now (no matter if
single- oder multiline), Ctrl-A moves the cursor to the beginning of the current
line instead of selecting all text in the field.

The "Select All" menu entry selects all text in the field, so the selection
basically works, but Ctrl-A is misinterpreted.


Reproducible: Always
Steps to Reproduce:
1. Enter text in a form text field
2. Hit Ctrl-A
3.

Actual Results:  
Cursor is at beginning of line, no text selected.

Expected Results:  
All text should have been selected.
(Reporter)

Comment 1

14 years ago
P.S.: Same problem for the URL field and all dialog text fields...
duplicate of bug 72352 / bug 257405; picking the latter. in 1.7.4 or .5 (and
1.8) mozilla should behave like you want it to. (unless you set the gtk pref to
use emacs keybindings)

*** This bug has been marked as a duplicate of 257405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.