Password manager can not handle multiple login fields correctly

VERIFIED DUPLICATE of bug 222589

Status

()

Toolkit
Password Manager
--
major
VERIFIED DUPLICATE of bug 222589
13 years ago
9 years ago

People

(Reporter: Thomas Scheffler, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041109 Firefox/1.0

Since the Firefox browser uses another password manager as Mozilla SeaMonkey it
seems that it does not handle logins consisting of more than one input field.
The example URL illustrates that for a bank accounting you have to enter 3
different numbers and a password. Oppose to Seamonkey Firefox is not aware of
the fact that the first three fields belong to the login and the last is the
password. In the password manager I noticed that it handles every odd field (1 &
3) as a single login and the even fields (2 & 4) as their corresponding
passwords. This makes no sence:

1.) only the 4th field is from type password (**** will show up)
2.) it makes no sence really to have to logins and passwords entered on the same
page at the same moment.

As the result the password manager is completly unuseful at this and probably
every similar site. I found no config property switching to the old (SeaMonkey)
behaviour with the popup so I fill out this bug for you :o)

Reproducible: Always
Steps to Reproduce:
1. load a page that consist of at least 2 login fields and one password field
2. try to use the password manager
3. switch back to SeaMonkey :o(

Actual Results:  
Seamonkey can't handle such sides.

Expected Results:  
It should handle it correctly may reenabling the old passwordmanager in such
cases would help. I'm not afraid of dialog boxes!

*** This bug has been marked as a duplicate of 222589 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.