Clicking on scrolling wheel (Microsoft IntelliMouse) on a hyperlink opens it up. Anyway to disable it?

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: alamoboy, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I click on the scrolling wheel on a Microsoft IntelliMouse to activiate or
deactiveate the mouse scrolling(*), if the mouse cursor happens to be over a
hyperlink it will open it in a New Tab.  In Internet Explorer, one can click
almost anywhere on the current webpage to activate/deactivate the mouse
scrolling, even it is on a hyperlink.  However, in FireFox, I have to be
cautious as to where I click the mouse wheel so as to prevent opening a New Tab
(and subsequently having to close it).


(*) Mouse scrolling being I don't have to turn the wheel to scroll up and down
or left and right on the page.  All I have to do is move the mouse around and
the page will scroll accordingly after it has been activated.

Reproducible: Always
Steps to Reproduce:
1. Depress the mouse wheel over a hyperlink and it will open
2.
3.

Actual Results:  
A New Tab appears with the hyperlink that I just clicked on.

Expected Results:  
Nothing (at least that's what happens in Internet Explorer).
This is by design
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Summary: Clicking on scrolling wheel (Microsoft IntelliMouse) on a hyperlink opens it up. Anyway to disable it? → Clicking on scrolling wheel (Microsoft IntelliMouse) on a hyperlink opens it up. Anyway to disable it?
You need to log in before you can comment on or make changes to this bug.